CiscoWorks LMS Data base

Unanswered Question
Nov 12th, 2007
User Badges:

Hello,


For more than ones I had the following problem:


When I installed the CommonServices if the LMS 2.6 I want to continue to install the CampusManager and other compenents it can't continue as the service of the CW doaemon won't to stop.

I that case I changed the service to manual start up.

After completing the installation, the C lost the connecton with the licensing server?? and any compenent won't to run unless all services are running??


Is it due that what I did? Do I can do that in a another manner to stop the service to let the other compenents to be installed?


Sincerely

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Mon, 11/12/2007 - 08:47
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Sometimes you need to set CiscoWorks Daemon Management to Manual, then reboot to install updates. Provided you set the service back to Automatic, then reboot again, everything should come back up. Note: do NOT change any of the other services' startup parameters as this will break LMS.

omar.elmohri Mon, 11/12/2007 - 12:54
User Badges:

That's OK


Butnow my problem is that I uninstalled all CiscoWorks, and I installed it back again and the problem still the same?

Joe Clarke Mon, 11/12/2007 - 13:04
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Shutdown CiscoWorks, then post the output of netstat -a -n -o -b.

omar.elmohri Wed, 11/14/2007 - 06:41
User Badges:

I reinstalled all LMS. But the problem still the same.


On the process I see that the DCAServer Never started unless all services are running.


That can be caused by Windows? I have a Windows 2003 R2.


Other processes like ANIServer and others are also down.


Any explain??

Joe Clarke Wed, 11/14/2007 - 08:50
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Not without more information. You will need to enable DCR debugging, but in LMS 2.6, this is not a straightforward process. Therefore, I recommend you open a TAC service request so that they can guide you through this.

omar.elmohri Wed, 11/14/2007 - 10:34
User Badges:

Is that problem still unless I reinstall Windows? because that's what I did.


I installed Windows, next the CommonServices. just before I tried to see, and I found that problem. and I installed before this copie of LMS, so there isn't a problem with the media.


I need to have a license to open a TAC service, and I'm using now an evaluation.

Joe Clarke Wed, 11/14/2007 - 10:53
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Unfortunately, without a debug log, I cannot say exactly what the problem is. This may be database related, hostname related, certificate related, or something else. Please post screenshots of all of your services in the Services control panel as well as the output of pdshow.

omar.elmohri Thu, 11/15/2007 - 05:00
User Badges:

Hello,


do there is somethings to avoid during installation or before installing, because the problem apears at my first installation. unless the same disk I used it before form many installations.

Joe Clarke Thu, 11/15/2007 - 08:14
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

The only thing I recommend doing prior to a Windows installation is to disable anti virus software, and if this is Windows 2003, set the TEMP and TMP environment variables to something short like C:\WINDOWS\TEMP.

omar.elmohri Tue, 11/20/2007 - 10:59
User Badges:

Hello,


When doing a self-test, the network.pl faild and announces that there is an nslookup failure

Joe Clarke Tue, 11/20/2007 - 11:02
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

what is the specific failure message? It could be you lack a proper resolver configuration, or it could just be safe to ignore.

omar.elmohri Tue, 11/20/2007 - 13:07
User Badges:

On the server, DNS is OK, and the server is not a domain memeber, and I don't think that it needs to be.


If there is some specific DNS configuration for LMS?

Joe Clarke Tue, 11/20/2007 - 15:25
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You need to make sure the server's short hostname and fully qualified hostname are resolvable as well as the server's IP address, localhost and 127.0.0.1.


These IPs and hostnames can be resolvable either via DNS or by local hosts file.

omar.elmohri Sun, 11/25/2007 - 03:14
User Badges:

I can access the localhost and also the

but I cannot access using 127.0.0.1:1741.


There is no problem when I access the web server of LMS. But it cannot syncronize with the DCR and licensing server also. so the CampusManager don't work.

Joe Clarke Sun, 11/25/2007 - 11:15
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

If 127.0.0.1 doesn't work, you will need to fix the IP configuration on your server. The loopback interface and 127.0.0.1 must be bound.

Actions

This Discussion