UC520 some outgoing calls fails

Unanswered Question
Nov 12th, 2007

Hi to all,

Last week I installed my first UC520, it works fine (it's a small CCME-CUE), but I have a problem outgoing calls.

Whit some PSTN numbers it seem the UC forward to telco wrong number (because I receive by telco e voice message), it seems that there is not a rules (like prefix or port), if I use a ISDN telephone directly connect to the telco BRI this number, that with UC520 fail, work fine! For expample if I do with ISDN phone the number 02 25478 the is established and works, with UC520 the same number I receive a prompt by telco. Other numbers works fine, other fails!!!

Any ideas? How can I show the number is forwarded to telco BRI? Which is the possible problem?

thank you very much.

----------------------

!

voice-port 0/0/0

timeouts ringing infinity

!

voice-port 0/0/1

timeouts ringing infinity

!

voice-port 0/0/2

timeouts ringing infinity

!

voice-port 0/0/3

timeouts ringing infinity

!

voice-port 0/1/0

compand-type a-law

cptone IT

bearer-cap Speech

!

voice-port 0/1/1

compand-type a-law

cptone IT

bearer-cap Speech

!

voice-port 0/4/0

auto-cut-through

signal immediate

input gain auto-control -15

description Music On Hold Port

!

sccp local Loopback0

sccp ccm 10.1.1.1 identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

!

!

dial-peer voice 1 pots

preference 7

service stcapp

port 0/0/0

!

dial-peer voice 2 pots

service stcapp

port 0/0/1

!

dial-peer voice 3 pots

service stcapp

port 0/0/2

!

dial-peer voice 4 pots

service stcapp

port 0/0/3

!

dial-peer voice 5 pots

description ** MOH Port **

destination-pattern ABC

port 0/4/0

no sip-register

!

dial-peer voice 50 pots

preference 7

destination-pattern 0T

incoming called-number 31444444

direct-inward-dial

port 0/1/0

no sip-register

!

dial-peer voice 51 pots

preference 10

destination-pattern 0T

incoming called-number 31555555

direct-inward-dial

port 0/1/1

no sip-register

!

dial-peer voice 999 voip

description TO_VoiceMail_CUE

destination-pattern 999

session protocol sipv2

session target ipv4:10.1.10.1

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 900 voip

description TO_AutoAttend_CUE

destination-pattern 9..

session protocol sipv2

session target ipv4:10.1.10.1

dtmf-relay sip-notify

codec g711ulaw

no vad

!

!

!

!

telephony-service

video

load 7960-7940 P0030702T023

load 7914 S00104000100

load 7902 CP7902080001SCCP051117A

load 7921 CP7921G-1.0.1

load 7931 SCCP31.8-1-1SR2S

load 7941GE TERM41.7-0-3-0S

load 7941 TERM41.7-0-3-0S

load 7961GE TERM41.7-0-3-0S

load 7961 TERM41.7-0-3-0S

load 7971 TERM70.7-0-3-0S

load 7970 TERM70.7-0-3-0S

load 7936 cmterm_7936.3-3-5-0

load 7906 SCCP11.8-0-3S

load 7911 SCCP11.8-0-3S

max-ephones 14

max-dn 56

ip source-address 10.1.1.1 port 2000

auto assign 10 to 19

auto assign 5 to 8 type anl

calling-number initiator

timeouts interdigit 3

timeouts ringing 120

url services http://10.1.10.1/voiceview/common/login.do

url authentication http://10.1.10.1/voiceview/authentication/authenticate.do

user-locale IT

network-locale IT

time-zone 5

time-format 24

date-format dd-mm-yy

voicemail 999

max-conferences 8 gain -6

call-forward pattern .T

call-forward system redirecting-expanded

multicast moh 239.10.16.16 port 2000

dn-webedit

time-webedit

transfer-system full-consult dss

transfer-pattern .T

secondary-dialtone 0

create cnf-files version-stamp 7960 Nov 09 2007 08:57:52

!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Mon, 11/12/2007 - 10:33

Hi Augusto,

first of all with the italian plan you can set so external calls are made without0, just make sure you extensions do not begig with 1, 3, or 8. Generally users will like that is makes more natural to call and recall numbers/

the you can reduce the DPs by placinf the interface in trunk-group

int bri0/x

trunkgroup ti

and use that instead of port in DP:

dial-peer voice 1

desc decade 1,81x

destination-pattern [18]..T

forward-digits all

trunkgroup ti

dial-peer voice 3

desc nazionali

destination-pattern 0[2-9]....T

forward-digits all

trunkgroup ti

dial-peer voice 3

desc internazionali

destination-pattern 00[2-9]....T

forward-digits all

trunkgroup ti

dial-peer voice 0

desc cellulari

destination-pattern ^3[2-4689].......T

forward-digits all

trunkgroup ti

then check which numbers are sent with "debug isdn q931" and "term mon".

Then there are few more customizations, but for now fix this and we'll see more later.

a.crippa Tue, 11/13/2007 - 00:59

Hi,

I tryied to implement your configuration but it does not work, when place a new call I obtain always the busy tone. I had removed the "second-dialtone 0", and I keep the "incoming called-number 3144444".

Other idea?

here my sh run:

interface BRI0/1/0

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

isdn incoming-voice voice

isdn k 7

trunk-group ti

!

interface BRI0/1/1

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

isdn incoming-voice voice

isdn k 7

!

interface Vlan1

description $FW_INSIDE$

ip address 192.168.10.1 255.255.255.0

ip access-group 102 in

ip nat inside

ip virtual-reassembly

!

interface Vlan100

description $FW_INSIDE$

ip address 10.1.1.1 255.255.255.0

ip access-group 103 in

ip nat inside

ip virtual-reassembly

!

ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0

!

ip http server

ip http authentication local

ip http secure-server

ip http path flash:

ip nat inside source list 1 interface FastEthernet0/0 overload

!

access-list

...

!

control-plane

!

!

!

voice-port 0/0/0

timeouts ringing infinity

!

voice-port 0/0/1

timeouts ringing infinity

!

voice-port 0/0/2

timeouts ringing infinity

!

voice-port 0/0/3

timeouts ringing infinity

!

voice-port 0/1/0

compand-type a-law

cptone IT

bearer-cap Speech

!

voice-port 0/1/1

compand-type a-law

cptone IT

bearer-cap Speech

!

voice-port 0/4/0

auto-cut-through

signal immediate

input gain auto-control -15

description Music On Hold Port

!

sccp local Loopback0

sccp ccm 10.1.1.1 identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

!

!

dial-peer voice 1 pots

preference 7

service stcapp

port 0/0/0

!

dial-peer voice 2 pots

service stcapp

port 0/0/1

!

dial-peer voice 3 pots

service stcapp

port 0/0/2

!

dial-peer voice 4 pots

service stcapp

port 0/0/3

!

dial-peer voice 5 pots

description ** MOH Port **

destination-pattern ABC

port 0/4/0

no sip-register

!

dial-peer voice 50 pots

description Nazionali

preference 7

destination-pattern 0[1-9]....T

incoming called-number 31444444

trunk-group-label target ti

direct-inward-dial

port 0/1/0

forward-digits all

no sip-register

!

dial-peer voice 51 pots

description Internazionali

preference 10

destination-pattern 00[1-9]....T

incoming called-number 31555555

trunk-group-label target ti

direct-inward-dial

port 0/1/1

forward-digits all

no sip-register

!

dial-peer voice 999 voip

description TO_VoiceMail_CUE

destination-pattern 999

session protocol sipv2

session target ipv4:10.1.10.1

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 900 voip

description TO_AutoAttend_CUE

destination-pattern 9..

session protocol sipv2

session target ipv4:10.1.10.1

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 52 pots

description Cellulari

destination-pattern ^3[1-4689].......T

trunk-group-label target ti

forward-digits all

!

!

!

!

telephony-service

....

max-ephones 14

max-dn 56

ip source-address 10.1.1.1 port 2000

auto assign 10 to 19

auto assign 5 to 8 type anl

calling-number initiator

timeouts interdigit 3

timeouts ringing 120

url services http://10.1.10.1/voiceview/common/login.do

url authentication http://10.1.10.1/voiceview/authentication/authenticate.do

user-locale IT

network-locale IT

time-zone 5

time-format 24

date-format dd-mm-yy

voicemail 999

max-conferences 8 gain -6

call-forward pattern .T

call-forward system redirecting-expanded

multicast moh 239.10.16.16 port 2000

dn-webedit

time-webedit

transfer-system full-consult dss

transfer-pattern .T

create cnf-files version-stamp 7960 Nov 13 2007 00:37:57

a.crippa Tue, 11/13/2007 - 01:18

I'm sorry here the right sh run o dial-peer, in this case also without 0 I obtain the same telco promp.

dial-peer voice 50 pots

trunkgroup ti

description Nazionali

destination-pattern 0[1-9]....T

incoming called-number 31444444

direct-inward-dial

forward-digits all

no sip-register

!

dial-peer voice 51 pots

trunkgroup ti

description Internazionali

destination-pattern 00[1-9]....T

incoming called-number 31555555

direct-inward-dial

forward-digits all

no sip-register

!

dial-peer voice 52 pots

trunkgroup ti

description Cellulari

destination-pattern ^3[1-4689].......T

trunk-group-label target ti

forward-digits all

Paolo Bevilacqua Tue, 11/13/2007 - 03:02

Hi Augusto,

Now enable "debug isdn q931" and "term mon" when making a call, send the output here.

a.crippa Tue, 11/13/2007 - 03:13

Hi,

here the output of the isdn debug.

This is one of case when I receive telco prompt.

Thank a lot for your help.

Augusto

Nov 13 11:07:41.401: ISDN BR0/1/0 Q931: Applying typeplan for sw-type 0x1 is 0x0 0x0, Calling num 202

Nov 13 11:07:41.405: ISDN BR0/1/0 Q931: Applying typeplan for sw-type 0x1 is 0x0 0x0, Called num 02962871

Nov 13 11:07:41.405: ISDN BR0/1/0 Q931: TX -> SETUP pd = 8 callref = 0x63

Bearer Capability i = 0x8090

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x8A

Exclusive, B2

Progress Ind i = 0x8183 - Origination address is non-ISDN

Calling Party Number i = 0x0080, '202'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '02962871'

Plan:Unknown, Type:Unknown

Nov 13 11:07:41.489: ISDN BR0/1/0 Q931: RX <- SETUP_ACK pd = 8 callref = 0xE3

Channel ID i = 0x8A

Exclusive, B2

Nov 13 11:07:43.365: ISDN BR0/1/0 Q931: RX <- CALL_PROC pd = 8 callref = 0xE3

Nov 13 11:07:43.385: ISDN BR0/1/0 Q931: RX <- DISCONNECT pd = 8 callref = 0xE3

Cause i = 0x84C1 - Bearer capability not implemented

Progress Ind i = 0x8288 - In-band info or appropriate now available

Nov 13 11:07:44.837: ISDN BR0/1/0 Q931: TX -> RELEASE pd = 8 callref = 0x63

Nov 13 11:07:44.881: ISDN BR0/1/0 Q931: RX <- RELEASE_COMP pd = 8 callref = 0xE3

Paolo Bevilacqua Tue, 11/13/2007 - 03:27

Hi Augusto,

I had forgot the most important thing. Please configure:

voice-port 0/0/0

compand-type a-law

Also you don't need "k 7" under BRI interfaces.

this is the translation-profile to add zeros for recall. Use it under the trunkgroup for incoming:

voice translation-profile ti-tg-in

translate calling 100

voice translation-rule 100

rule 1 // /0/ type national national

rule 2 // /00/ type international international

Hope this helps, please rate post if it does!

a.crippa Tue, 11/13/2007 - 03:46

Hi,

The voice port was already configured with compand-type and cptone

voice-port 0/1/0

compand-type a-law

cptone IT

bearer-cap Speech

!

voice-port 0/1/1

compand-type a-law

cptone IT

bearer-cap Speech

From isdn output it seems that CCME sent right number to telco BRI, right?

Thank for traslation rules.

Thank a lot.

Augusto

Paolo Bevilacqua Tue, 11/13/2007 - 04:53

Hi Augusto,

The number is right but bearer capability sent is not like should be:

Nov 13 13:52:36.091 CET: ISDN BR0/2/0 Q931: TX -> SETUP pd = 8 callref = 0x3B

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x89

Exclusive, B1

Progress Ind i = 0x8183 - Origination address is non-ISDN

Calling Party Number i = 0x0080, '28'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '187'

Plan:Unknown, Type:Unknown

Sending Complete

Nov 13 13:52:36.163 CET: ISDN BR0/2/0 Q931: RX <- CALL_PROC pd = 8 callref = 0xBB

Channel ID i = 0x89

Exclusive, B1

I always used "isdn sending-complete" alos, see if it helps.

a.crippa Wed, 11/14/2007 - 01:55

Hi to all,

my problem is a bug in UC520 IOS 12.4(11)XW, I resolved it download and upgrade the IOS to 12.4(11)XW4, now it works fine!

Thank for your patient.

Augusto.

Paolo Bevilacqua Wed, 11/14/2007 - 02:00

Just the thing that I wanted to say and then I did not :)

Please come back at any time, thanks, Paolo.

Actions

This Discussion