LMS integration with ACS

Unanswered Question
Nov 12th, 2007
User Badges:

Hi,


I have a LMS 3.0 integrated into ACS 4.1. After integration the LMS is too slow when opening and even during the navigation into the menus.


can somebody help me?


with thanks

sathappan.s

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Mon, 11/12/2007 - 08:35
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

All I can offer given what you have provided is to check the network between the ACS and LMS servers. Rule out obvious performance issues like faulty cabling, duplex mismatches, etc. Also, check that both servers meet minimum requirements, and check the load to make sure there aren't any processes monopolizing CPU time.

a.olsthoorn Sun, 01/13/2008 - 15:09
User Badges:

We als o had the same problem with LMS 3.0 & ACS 401 appliance. Also bad performance seen. When changed form ACS mode to Non CS mode this cpu problem dissapeared. Could you explain under what circomstances you worked or set this up. How can I check this?


I checked the network, nothing found.


Regards

Ad Olsthoorn

Joe Clarke Sun, 01/13/2008 - 18:20
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This is the first I've heard of a CPU problem. What processes were taking up a lot of CPU? What are the stats of the CiscoWorks server


Lab tests will LMS/ACS integration were done with servers on the same LAN or otherwise ethernet connected. We tested with ACS on Windows and on the appliance platform.


I personally have LMS 2.6 and 3.0 integrated with ACS 4.0 running on a Windows server. Both ACS and LMS servers are in the same subnet interconnected on 100 Mbps ports on 2960 switches. I have not seen any unusual performance problems with this setup.

Hi,

I integrate LMS 3.0 with ASC 4.1 solution engine today and the same situation appeared. Before the ASC integration (with local CW authentication) everything worked fine. Now the performance of the GUI is poor. The network connection of the CW even ACS didn't changed and both servers are on the same LAN. I also tried different web browsers and the CW GUI performance is always poor.

Regards,

Tomas

Joe Clarke Tue, 02/26/2008 - 17:53
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

We have seen this kind of problem if LMS is installed on Windows. In that case, if the IP address of the ACS server is not resolvable, then LMS ends up sending directed NetBIOS queries to the ACS box. Try adding the ACS server's hostname and IP address to C:\WINDOWS\system32\drivers\etc\hosts, and see if that helps.

wiparra Tue, 04/08/2008 - 10:35
User Badges:
  • Cisco Employee,

Hi:


Actually I am having the same problem in a similar installation (LMS 3.0 and ACS). The initial problem persists after applying this suggestion. Is there any other solution? Our customer had changed to a more powerfull server in order to improve the response time of LMS Navigation but no improved results.

Thanks,

Joe Clarke Tue, 04/08/2008 - 15:48
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

The next step is to start a sniffer trace filtering on all traffic between the ACS server and LMS while reproducing things that take longer than they should. This will help isolate whether or not the problem is network-related.

kvbjokvbjo Wed, 12/17/2008 - 07:30
User Badges:

The solution for me (after the same problem) was simply to add the name and ip address of the ACS in the hosts (windows/system32/drivers/etc/hosts.txt) file on the LMS-server. After that the LMS-server responded fast again. Thanks to jclark for this tip!


Bjorn Olsson


Actions

This Discussion