Help: ISDN-BRI circuit only stays up for 20s??

Unanswered Question
Nov 12th, 2007

I have a 128 ISDN circuit. When I initiate an ISDN test call, the circuit drops everytime after 20s...some debug info. is below:

49w2d: BR1/0:1 LCP: EndpointDisc 1 fau_la (0x1309016661755F6C61)

49w2d: BR1/0:1 LCP: TIMEout: State REQsent

49w2d: BR1/0:1 LCP: State is Listen

30064771072w210453397504d: %ISDN-6-DISCONNECT: Interface BRI1/0:1 disconnected from 16197104252 , call lasted 20 seconds

49w2d: ISDN BR1/0 Q931: TX -> DISCONNECT pd = 8 callref = 0x41

Cause i = 0x8090 - Normal call clearing

49w2d: ISDN BR1/0 Q931: RX <- RELEASE pd = 8 callref = 0xC1

30064771072w210453397504d: %LINK-3-UPDOWN: Interface BRI1/0:1, changed state to down

49w2d: ISDN BR1/0 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x41

49w2d: BR1/0:1 PPP: Sending Acct Event[Down] id[9A]

49w2d: BR1/0:1 LCP: State is Closed

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Mon, 11/12/2007 - 09:09

RADHAY

It looks to me as if this debug starts after some call processing has already been done. And I do not see anything here that clearly shows what the issue is. I would suggest that you run a debug that starts well before the call is made. It might also be helpful to run debug ppp negotiate and debug ppp authenticat and to post their output.

HTH

Rick

rshiamsundar Mon, 11/12/2007 - 09:18

I just posted some of the debug messages...I'll redo and post all...Thanks.

Richard Burts Mon, 11/12/2007 - 10:23

RADHAY

Thank you for posting the additional debug results and I believe that they are helpful. I believe that the debug results show clearly that your router is initiating the call and is attempting to negotiate ppp parameters, and that your router is receiving no response from the device on the other end. I have looked briefly at the config that you posted and do not see any particular issues with it. I believe that the problem is in the device on the other end of the connection. What can you tell us about that device?

HTH

Rick

rshiamsundar Mon, 11/12/2007 - 11:16

The device on the other end is a cisco 2600 router with its BRI0/0 port config. below; one strange thing is when I dial the 6197104203 number, I get normal ringback tones indicating to me it's like a regular telephone number. I would think I should get some kind of authenticating signals since an ISDN circuit:

interface BRI0/0

description Backup Backhaul to North Las Vegas Hub

ip address 192.1.2.2 255.255.255.0

encapsulation ppp

no ip mroute-cache

dialer idle-timeout 900

dialer fast-idle 50

dialer map ip 192.1.2.1 name fau_la broadcast 17026570215

dialer map ip 192.1.2.1 name fau_la broadcast 17026570755

dialer hold-queue 5

dialer load-threshold 1 either

dialer-group 1

isdn switch-type basic-ni

isdn spid1 61971042030101 7104203

isdn spid2 61971042520101 7104252

no fair-queue

ppp callback request

ppp authentication chap

ppp multilink

ppp timeout idle 90

end

Richard Burts Mon, 11/12/2007 - 11:43

RADHAY

The configuration of the other end is quite consistent with the configuration of your router and I do not yet see a problem in the parts of the config that we see. Would it be possible to get debugs from the 2600 when you attempt to initiate the call from your router?

HTH

Rick

Richard Burts Mon, 11/12/2007 - 12:34

RADHAY

This debug is very interesting. It does show the incoming call. It does show the incoming attempt to negotiate:

I CONFREQ [Listen] id 229 len 31

and

I CONFREQ [REQsent] id 231 len 31

and it shows outbound attempts to negotiate:

O CONFREQ [Listen] id 229 len 28

and

O CONFREQ [REQsent] id 230 len 28

but it seems that the attempt to negotiate does not get back to the 2800.

And I am very puzzled to find this in the midst of the attempts to negotiate:

%ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 7026570215 fau_la

apparently the 2600 thinks that it is connected even while attempts to negotiate continue.

I wonder if another test done with running debug isdn q931 (hopefully on both routers) might shed some light on what is happening.

HTH

Rick

jvalin__s Tue, 11/13/2007 - 23:27

well Mr rshiamsundar.

if u r calling u r giving a test call on mobile then i guess it will last only for 20 seconds.

I had the same situation when I was testing it.

but just try to shut the mail line ( leased line or MPLS or any)

and then check it. it will work correctly

Actions

This Discussion