IOS Upgrade Problem

Unanswered Question
Nov 12th, 2007

I am working in a lab environment with 3 1760's. I had some problems keeping my router secure because of people using password recovery to change my configuration. I decided to disable password-recovery which disables ROMMON completely. The same day I upgraded the IOS in one of the 1760's to run voice without even checking if my hardware could support the new IOS. When I reloaded, it couldn't load the image because I didn't have enough RAM. Now the router won't load up and I can't get into ROMMON to change the image. Does anyone have any ideas what to do? I cannot upgrade the RAM or Flash, but I can't switch between the 3 1760's. I tried switching the flash cards but apparently the no service password-recovery command saves onto the flash and none of my 1760's has enough RAM to load the image to change it.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
JORGE RODRIGUEZ Tue, 11/13/2007 - 13:53

Hi, never ran into this situation and will be open to hear more comments on how to solve it, but it seems you will have to either buy more RAM or buy a spare flash.

JORGE RODRIGUEZ Tue, 11/13/2007 - 19:07

Brian, reading a bit fruther on software configuration registers "bit 8 disabling console brake key " you may be able to still brake into rommon, try it see if it works.

I quote from link, although this link talks about 2600 series it may or may not work for your router but worth the try.

"Bit 8 of the software configuration register controls the console Break key. Setting bit 8 causes the system to ignore the console Break key. This is the factory default. Conversely, clearing bit 8 causes the system to interpret a Break keystroke as a command to halt normal system operation and force the system into ROM monitor mode. Regardless of the setting of the Break enable bit in the software configuration register, pressing the Break key during approximately the first five seconds of booting causes a return to the ROM monitor"

Brian Meade Tue, 11/13/2007 - 20:20

I was able to finally fix the router today. I found a 2600 with spare DRAM and I borrowed it just long enough for me to boot the 1760 and change the configuration to allow password-recovery. Thanks for all your help guys!


This Discussion