2851 looping with bvi interface

Answered Question
Nov 12th, 2007

Hi all,


Just wondering if someone can provide some assistance with my issue.


Just installed a new 2851. Both ethernet interfaces (gi0/0 & gi0/1) are configured for a bridge-group. Both of these ports are connected to a 3750 switch.


The issue is when I connect both physical cables to the gi0/0 and gi0/1 it creates a loop. Disconnect one of them and it's fine. It appears as though spanning-tree is not working properly.


Can anyone suggest a place for me to look at within my config? (Router or switch). Some of the config below:


2851 router:

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

no mop enabled

bridge-group 140

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

no mop enabled

bridge-group 140

interface BVI140

description VLAN 140

ip address 10.1.1.70 255.255.248.0

no ip proxy-arp

ip nat inside

ip ips sdm_ips_rule out

ip virtual-reassembly

zone-member security in-zone

ip route-cache flow


3750:

interface GigabitEthernet2/0/31

description Cisco 2851 Router

switchport access vlan 140

switchport mode access

switchport block multicast

switchport block unicast

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust cos

auto qos voip trust

storm-control broadcast level 1.00

spanning-tree guard root

interface GigabitEthernet2/0/32

description Cisco 2851 Router

switchport access vlan 140

switchport mode access

switchport block multicast

switchport block unicast

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust cos

auto qos voip trust

storm-control broadcast level 1.00

spanning-tree guard root


Thanks

Correct Answer by Edison Ortiz about 9 years 3 months ago

The router isn't running any spanning-tree therefore the switch is not able to block one port to prevent the loop.


Can you post the router's entire config ?


You must have

bridge 140 protocol ieee

bridge irb

bridge route ip


on the router's config.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
gregsmales Mon, 11/12/2007 - 16:52

output from 2851: (however only one interface out of the two is currently active)


2851-01#sh spanning-tree


No spanning tree instances are running.


output from 3750: (the 2851 is connected to gi2/0/31 and gi2/0/32)

VLAN0140

Spanning tree enabled protocol rstp

Root ID Priority 140

Address 0013.c386.ab40

Cost 3

Port 616 (Port-channel1)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec


Bridge ID Priority 32908 (priority 32768 sys-id-ext 140)

Address 0014.a9ec.fd00

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300


Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Gi1/0/16 Desg FWD 19 128.16 Edge P2p

Gi1/0/17 Desg FWD 19 128.17 Edge P2p

Gi1/0/18 Desg FWD 19 128.18 Edge P2p

Gi1/0/19 Desg FWD 100 128.19 Edge Shr

Gi1/0/21 Desg FWD 19 128.21 Edge P2p

Gi1/0/40 Desg FWD 19 128.40 P2p

Gi1/0/42 Desg FWD 19 128.42 P2p

Gi1/0/44 Desg FWD 19 128.44 P2p

Po1 Root FWD 3 128.616 P2p

Po2 Desg FWD 3 128.624 P2p

Po3 Desg FWD 3 128.632 P2p

Gi2/0/9 Desg FWD 4 128.61 Edge P2p

Gi2/0/10 Desg FWD 19 128.62 Edge P2p

Gi2/0/11 Desg FWD 19 128.63 Edge P2p

Gi2/0/12 Desg FWD 4 128.64 Edge P2p

Gi2/0/13 Desg FWD 4 128.65 Edge P2p

Gi2/0/14 Desg FWD 4 128.66 Edge P2p

Gi2/0/17 Desg FWD 4 128.69 Edge P2p

Gi2/0/18 Desg FWD 19 128.70 Edge P2p

Gi2/0/19 Desg FWD 4 128.71 Edge P2p

Gi2/0/22 Desg FWD 4 128.74 Edge P2p

Gi2/0/31 Desg FWD 4 128.83 P2p

Gi2/0/39 Desg FWD 4 128.91 Edge P2p

Gi2/0/40 Desg FWD 19 128.92 P2p

Gi2/0/41 Desg FWD 4 128.93 Edge P2p

Gi2/0/42 Desg FWD 19 128.94 P2p

Gi2/0/44 Desg FWD 19 128.96 P2p

Correct Answer
Edison Ortiz Mon, 11/12/2007 - 16:56

The router isn't running any spanning-tree therefore the switch is not able to block one port to prevent the loop.


Can you post the router's entire config ?


You must have

bridge 140 protocol ieee

bridge irb

bridge route ip


on the router's config.

gregsmales Mon, 11/12/2007 - 18:02

Ok, I had:


bridge irb

and

bridge 140 route ip


However I didn't have:

bridge 140 protocol ieee


I added the above into the config, and spanning-tree kicked in. Then connected the second physical link to the router and spanning-tree blocked the second port. All working perfectly now.


Thanks a lot for your help!

Actions

This Discussion