Cisco Switches/Routers and Avaya VoIP phones

Unanswered Question

I recently inherited a small Cisco network that is using Avaya VoIP phones. Since the previous administrator knew nothing about networks, everything was configured in 1 large VLAN. Now, I am trying to move the phones over to a 172.16.128.x/24 VLAN to seperate voice traffic from data traffic. the general switch (a Cisco 3750) port configuration is this:

interface FastEthernetx/x/x

switchport access vlan 128

switchport trunk encapsulation dot1q

switchport trunk native vlan 128

switchport mode trunk

switchport voice vlan 130

load-interval 30

mls qos trust cos

no cdp enable

spanning-tree portfast

spanning-tree bpdufilter enable

Once you configure the port with the above settings and reset the phone, the phone does come up on it's new IP settings (on the 172.16.130.x/24 subnet) and works fine, as does the PC. But before you reset the phone if you add the above port configuration and just reboot the phone (not do a reset), the phone comes back on it's older 172.17.x.x/22 IP settings and works just fine. Routing between VLAN's is done off of the 3750 on a subinterface configured on a 3745.

So my question is, since the phone seems to be pulling from DHCP and "then" pulling an IP address from the Avaya server (on the 172.17.x.x/22 subnet), why would it work on a subnet (172.16.130.x/24) for which it does not have an IP?

I'm no Avaya or VoIP expert (but i'm working on it), so I wanted to see if someone with more experience might know. Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
n.rungjitwaranon Mon, 11/12/2007 - 19:22


I'm not sure about your network configuration but from my experience with Avaya phones, you need only these commands;

interface fax/x/x

switchport trunk encapsulation dot1q

switchport mode trunk

swithport trunk native vlan [data vlan]

switchport trunk allowed vlan [data,voice] ! optional... just limit your broadcast domain.

I think the command "switchport voice vlan" just works with Cisco phones because it uses CDP to detect voice VLAN.

The rest of the configurations could be added manually on your Avaya phones or in the DHCP scope option number "176". You can add the following parameters in the scope option;

MCIPADD; C-LAN IP address(es)

MCPORT; default is 1719

TFTPSRVR; TFTP server (for upload phone's firmware)

L2QVLAN; Add your voice VLAN here.

i.e. option 176: MCIPADD=172.17.x.x,MCPORT=1719,L2QVLAN=130

And dont forget to relay your DHCP queries in your voice VLAN to the correct DHCP server.

interface vlan [voice VLAN]

ip helper-address 172.17.x.x


This Discussion