Static Default Routes won't Load Balance

Unanswered Question
Nov 12th, 2007

I am trying to staticly load balance between two ISP's. One connection is Ethernet the other DSL. My route statements are as follows

ip route dialer 0

ip route

show ip route

Routing entry for, supernet

Known via "static", distance 1, metric 0 (connected), candidate default path

Routing Descriptor Blocks:


Route metric is 0, traffic share count is 1

directly connected, via Dialer0

Route metric is 0, traffic share count is 1

Internal network traffic always uses the route but internally generated router traffic will load balance. If the interface connected to fails, all traffic will use the Dialer 0. Without administrative distance modification, I would expect the dialer to be the prefered route as it is a static route to an interface (i.e. connected route).

While experimenting I've tried raising the A.D. of both routes to 5. I've tried "ip route fastethernet 0/0" I've disabled CEF and set "no ip route-cache" but I can't get internal traffic to load balance.

Does the fact that a Dialer interface is "Spoofed." have any impact on the route?

Any ideas would be greatly appreciated?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Richard Burts Mon, 11/12/2007 - 20:22


The fact that the Dialer is spoofed should have no impact on the routes. Could you post the output of show ip route from this router?



mspiegelman Mon, 11/12/2007 - 21:00

Gateway of last resort is to network is subnetted, 1 subnets

C is directly connected, FastEthernet0/0 is subnetted, 2 subnets

C is directly connected, Dialer0 is subnetted, 5 subnets

C is directly connected, FastEthernet0/1

S [1/0] via is subnetted, 1 subnets

C is directly connected, Dialer0

S* [1/0] via

is directly connected, Dialer0

Richard Burts Tue, 11/13/2007 - 03:35


This is certainly not what I expected. These lines:

S* [1/0] via

is directly connected, Dialer0

seem to associate address with interface dialer0 and not with FastEthernet0/0. Can you post the output of show interface FastEthernet0/0 and also the output of show ip interface brief?



mspiegelman Tue, 11/13/2007 - 11:49

You may have been confused by the fact that this website removes extra spaces. Please view the route to as ...

S* [1/0] via

-------------is directly connected, Dialer0

You will notice my original post shows the configured routing entries (including the one to the dialer interface) and a the output of "show ip route"

The routing table looks good to me. Unfortunately, traffic received on an interface NEVER takes the dialer interface unless the interface goes down.

The problem appears to be related to PPPoE, virtual-templates, the dialer interface, or something the dsl provider is configuring via my "ip address negotiated" interface.

1841#show ip int br

Interface IP-Address OK? Method Status Prot


FastEthernet0/0 YES manual up up


NVI0 unassigned YES unset up up

Virtual-Access1 unassigned YES unset down down

Virtual-Access2 unassigned YES unset up up

Virtual-Template2 YES TFTP down down

Dialer0 YES IPCP up up

Richard Burts Tue, 11/13/2007 - 13:53


Yes you are correct that I mis-interpreted the truncated spaces. (which is the second time today that I have misunderstood formatting of posted information) Thanks for clarifying.

I am surprised to see that the address specified in the static default route seems to be the address of the FastEthernet interface itself:

FastEthernet0/0 YES manual up up

I would expect this kind of static route to normally specify the next hop address. I am not clear what the impact is of using the interface address. I would have thought it would not work (since effectively we do not know how to forward past the interface) but wonder if in some perverse way it makes it more attractive?

Also at the risk of being a bit dense again, I wonder if there is significance in seeing the address associated with both Virtual-Template2 (where it is down down) and with Dialer0 where it is up up.

Perhaps we might get more of a handle on the issue if you would post the config of the router.




This Discussion