Troubleshooting dialplan.xml on 7940/SIP

Unanswered Question
Nov 13th, 2007
User Badges:

Hi,

I have a 7940 running SIP v7.04 with which I am having dialplan problems:

my tftp server serves amongst other things a dialplan.xml file (refered to in the SIPxxx.cnf configuration file) which is very simple:


<DIALTEMPLATE>

<TEMPLATE MATCH="6..." TIMEOUT="0">

<TEMPLATE MATCH="9,*" TIMEOUT="0">

</DIALTEMPLATE>


I know from the TFTP log files that the phone retrieves this file OK - however, the dialplan is not taken into account by the phone, and when I log in the phone and do a "sh dialplan" it is empty.


When I do a "sh status", I get:


Current Phone Status

--------------------

W350 unprovisioned proxy_backup

W351 unprovisioned proxy_emergency

W320 2 Error(s) Parsing: SIP000xxx.cnf

W330 2 Error(s) Parsing: dialplan.xml


I presume that the errors are why the dialplan is not applied, but can't find any way of finding out more details:


Can someone either spot a problem in my dialplan, or even better, explain how to find out what the errors are?


Thanks in advance,


Olivier

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
olivier.vigneresse Tue, 11/20/2007 - 14:12
User Badges:

Found the problem!

Can't believe it took me so long - it was so obvious: malformed XML was simply the problem; I'd forgotten to close the tag: the should in fact have been - note the / at the end!


It's all working now - does anyone know of a way to actually get some sort of debug out of the XML paser in the 7900?

Actions

This Discussion