Configure 2511 as a terminal server

Unanswered Question
Nov 13th, 2007

I have a 2511 with an octal cable attached to the Async 1-8 port. Config is listed below:

sh run

Building configuration...

Current configuration:

!

version 11.2

no service password-encryption

no service udp-small-servers

no service tcp-small-servers

!

hostname TermServer

!

enable password cisco

!

partition flash 2 8 8

!

ip subnet-zero

no ip domain-lookup

!

interface Loopback0

ip address 100.100.100.100 255.255.255.255

!

interface Ethernet0

ip address <address removed>

!

interface Serial0

no ip address

shutdown

!

interface Serial1

no ip address

shutdown

!

interface Async1

no ip address

async mode interactive

!

interface Async2

no ip address

async mode interactive

!

!

ip classless

!

line con 0

password cisco

logging synchronous

login

line 1 16

no exec

exec-timeout 0 0

transport input all

stopbits 1

flowcontrol hardware

line aux 0

line vty 0 4

exec-timeout 0 0

privilege level 15

password cisco

logging synchronous

login local

transport input telnet

!

end

TermServer#

This is a capture of a session. The problem is that it I can make a connection to the remote device, but I cannot gain control of that device.

TermServer#telnet 100.100.100.100 2001

Trying 100.100.100.100, 2001 ... Open

TermServer#sh line

Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns

* 0 CTY - - - - - 5 0 0/0

* 1 TTY 9600/9600 - - - - - 3 0 0/0

* 2 TTY 9600/9600 - - - - - 2 0 0/0

3 TTY 9600/9600 - - - - - 0 0 0/0

4 TTY 9600/9600 - - - - - 0 0 0/0

5 TTY 9600/9600 - - - - - 0 0 0/0

6 TTY 9600/9600 - - - - - 0 0 0/0

7 TTY 9600/9600 - - - - - 0 0 0/0

8 TTY 9600/9600 - - - - - 0 0 0/0

9 TTY 9600/9600 - - - - - 0 0 0/0

10 TTY 9600/9600 - - - - - 0 0 0/0

11 TTY 9600/9600 - - - - - 0 0 0/0

12 TTY 9600/9600 - - - - - 0 0 0/0

13 TTY 9600/9600 - - - - - 0 0 0/0

14 TTY 9600/9600 - - - - - 0 0 0/0

15 TTY 9600/9600 - - - - - 0 0 0/0

16 TTY 9600/9600 - - - - - 0 0 0/0

17 AUX 9600/9600 - - - - - 0 0 0/0

18 VTY - - - - - 2 0 0/0

19 VTY - - - - - 0 0 0/0

20 VTY - - - - - 0 0 0/0

21 VTY - - - - - 0 0 0/0

--More--

TermServer#

When the connection shows open, pressing return multiple times does nothing. I can only regain control by shift-control 6 -X. Then I do a show line and you can see that I made a connection via the line.

So, the problem is that I am making a reverse telnet connection to the remote device by not gaining control. I have tried 3 different remote devices with different IOSs on them and three different ports on the Async

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
guruprasadr Tue, 11/13/2007 - 21:35

HI Jeffrey, [PLs Rate if HELPS]

Configuring a Cisco Router as Terminal Server:

---------------------------------------------

when you have a home lab you want to have console connectivity to all your routers at the same time. By using a terminal server (2509-2512 router range) we can accomplish this.

To use a terminal server we need a 2509/2510 8 lines or 2511/2512 16 lines router and 1 or 2 octal cables.

The first thing we do is create a loopback interface that will be used for the reverse telnet sessions from the other devices.

Router(config)#interface loopback0

Router(config-if)#ip address 172.16.1.1 255.255.255.255

Now we add the devices that are connected to this router [octable cable to each console port]

Router(config)#ip host hostname 2001 172.16.1.1

Router(config)#ip host hostname2 2002 172.16.1.1

The previous commands lets you use the hostname of the device to access it on it's console port. The portnumber is made of the following 200x where x is the nr on the octal cable going to that device. Depending on the type of router you use for terminal server you can have either 8 or 16 devices hanging of it.

Now that the router is configured we use the following commands to navigate.

- to access a device

telnet 172.16.1.1 2001

- to switch between active sessions

ctrl-shift-6-x will bring you back to terminal server

show sessions will display the active sessions

entering a number of a session will let you access that session

- to disconnect a session

use the disconnect command

Refer the CISCO Document attached (.pdf) for more help.

Pls Rate if HELPS

Best Regards,

Guru Prasad R

Actions

This Discussion