VoWiFi Guidelines Needed

Unanswered Question

I already installed several VoWiFi projects but all of them had the same problem: the wireless phone (7920 or 7921) decides to roam when it reaches the rssi +/- -75dBm (sometimes -80dBm), when there is a better option like -60dBm earlier, which causes voice gaps for 2 or 3 seconds. Does not happen all the time but it happens. I already adopt a few measures on the design like:

- Always use a controller

- I use 802.11bg for data and 802.11a for voice

- Minimum cell size for voice is -67dBm

- Disable all speeds below 11Mbps for voice

- Disable "dhcp required feature"

- I dont use "agreesive load balancing" for voice

- Auto-RF is enabled (DFS and DTPC)

Am I doing anything wrong? Is it really that hard to implement seamless roaming for VoWiFi?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
migilles Thu, 11/15/2007 - 08:21

Since referring to 802.11bg and 802.11a, will assume you are referring to the 7921 only here. For the 1.0.5 release, we are going to make the roaming more aggressive to where it can roam twice in a short period based on RSSI alone. This is due to come out mid December.

Voice quality should still be acceptable @ -75 and -80 dBm, but a little down from there (i.e. -85) can start to see degradation, but depends on the data rate.

For 7921 design guidelines, see the following:

http://www.cisco.com/univercd/cc/td/doc/product/voice/c_ipphon/english/wip7921/7921dply.pdf

john.preves Sat, 11/17/2007 - 18:01

How did the survey go? If you did the survey to where the end of the signal was at -67dBm at 11Mbps only, then you should roam. I suspect the power of the AP's and the phones themselves are too high. I turn the auto RF off and set the power pretty low, usually not over 20mW or 14dBm or whatever the Cisco number for that is. If you can get 2500 square feet out of a cell that is densely populated that's big enough. The physical load balancing by using lower power on both devices is what you are missing.

Hope this helps - it hasn't failed me yet.

john.preves Mon, 11/19/2007 - 13:06

Sorry to hear that, but this is a good learning experience for you.

You should actually use the device that will be in use on the network for the survey.

Software surveys are less than impressive.

migilles Sun, 11/18/2007 - 00:55

Another item that could cause this is if QBSS is not implemented. If you have the Cisco WLAN controller and have WMM enabled it will advertise the 802.11e QBSS (element 11). WMM should be enabled per guidelines.

TSPEC has precedence over QBSS for CAC though. QBSS can be used for roaming.

If autonomous, QBSS is disabled by default and 802.11e version is not enabled w/ WMM. Must enter "dot11 phone dot11e" command.

The issue above was found when testing with non-CCX compliant APs and this will also be resolved in the 1.0.5 release.

migilles Tue, 11/20/2007 - 19:19

The 802.11e version of QBSS is sent out when using 5 GHz on the Cisco WLC, but not the Cisco versions.

Encourage to use TSPEC for CAC since it's both directions.

Actions

This Discussion