Kevin Dorrell Wed, 11/14/2007 - 08:36
User Badges:
  • Green, 3000 points or more

An SVI is an interface that represents the gateway for a VLAN, in other words it is the router interface for a set of switchports on a VLAN.


A routed port is a physical interface that you have declared as no switchport. You are treating like the Ethernet interface of a router. It is essentially a point-to-point link to another router or to a routed port in another switch.


Kevin Dorrell

Luxembourg


Edison Ortiz Wed, 11/14/2007 - 08:38
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

A routed port is configuring an IP address under a switchport. This connection is considered point-to-point.


SwitchA

interface f0/0

no switchport

ip address 192.168.1.1 255.255.255.252


SwitchB

interface f0/0

no switchport

ip address 192.168.1.2 255.255.255.252


______________________




A SVI is a logical interface that represents a Vlan. This connection is accessible to all members on that Vlan holding a common IP subnet.


interface vlan 192

ip address 192.168.1.1 255.255.255.0


then you can have workstations with ip subnet 192.168.1.0/24 on the following ports


interface f0/0

switchport mode access

switchport access vlan 192


interface f0/1

switchport mode access

switchport access vlan 192


interface f0/2

switchport mode access

switchport access vlan 192



etc...



hi.622823 Wed, 11/14/2007 - 09:57
User Badges:

Wow, fast responses...


I do have one follow up question though, which relates to why I posted this question.


What is the difference between routing in the context of an L3 switch and a router (or routed port)? Let's assume the switch and router are running CEF.


Edison Ortiz Wed, 11/14/2007 - 10:06
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Sorry, I don't understand the question.

hi.622823 Wed, 11/14/2007 - 10:10
User Badges:

Ok, does it make sense to say an L3 switch does routing ie route table lookups?

Edison Ortiz Wed, 11/14/2007 - 10:12
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

yes.

hi.622823 Wed, 11/14/2007 - 10:18
User Badges:

Alrighty. What I was trying to get at is how is that functionality different from a traditional router (or is there something I'm missing)?

Edison Ortiz Wed, 11/14/2007 - 10:39
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

The functionality is the same from a traditional router. Many organizations have replaced traditional routers with Layer3 switches since they provide higher port density in addition to full routing services.

hi.622823 Wed, 11/14/2007 - 10:50
User Badges:

Great.


Thanks again everyone for your timely responses (especially Edison).


This is exactly the sort of thing that encourages quality participatiion in the Cisco forums.

prabhdeepnijjar Wed, 11/14/2007 - 23:33
User Badges:

to clear your confusion for the difference between L3 swith and router.Th L3 switch works using the hardware i.e the routing in them is hardware based and it is more fast .While the routers are software based .i.e they make decisions using the software which is much slower than the hardware based switching.

Actions

This Discussion