DHCP over 1300 Bridges

Unanswered Question
Nov 14th, 2007
User Badges:

I have 1300 bridges in station root and non-root mode and all the vlans can communicate across it with address assigned. But when a new unit (pc or phone) is attached.....the DHCP broadcast does not get sent across the wireless link to the DHCP server. What config change is needed to allow these broadcasts?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
bbxie Wed, 11/14/2007 - 17:49
User Badges:
  • Silver, 250 points or more

if the DHCP server and client are on different vlan, make sure DHCP relay is enabled in the attached router/L3 switch

johnminon Thu, 11/15/2007 - 06:16
User Badges:

The DHCP server is on a router with a fastethernet set up as a dot1q trunk with all the vlans attached as sub-interfaces.

It is the broadcast that is not going across the wireless connection.

If i were to apply DHCP relay...where would i put it???


srosenthal Thu, 11/15/2007 - 07:13
User Badges:

The DHCP relay would need to be on the first layer 3 interface that the broadcast will get to.

Do you have a switch attaced to the non-root bridge or are you just directly attaching a device to the bridge?

If you are using a switch, you will need to set the switchport to use the proper VLAN that you desire.

As for the DHCP scope being on the router, you need to be certain that is in the same network as the VLAN you are connecting to. If your switchport is setup for VLAN10, and you do not have scope defined in the network space for VLAN10, then you will not get an address.

DHCP scopes will only assign an address to a device that is in the same VLAN that it is established for.

Can you post the router config?


johnminon Thu, 11/15/2007 - 07:27
User Badges:

Her is the pertinent info from router:

no ip dhcp use vrf connected

ip dhcp excluded-address

ip dhcp excluded-address


ip dhcp pool ipphone



option 150 ip

domain-name pdcarea.lcl


interface Loopback0

ip address


interface FastEthernet0/0

description Trunk to sw1

no ip address

duplex auto

speed auto


interface FastEthernet0/0.200

description VLAN 200 Wireless Infrastructure

encapsulation dot1Q 200

ip address

no snmp trap link-status


interface FastEthernet0/0.300

description VLAN 300 Data xxxxx

encapsulation dot1Q 300

ip address

no snmp trap link-status


interface FastEthernet0/0.400

description VLAN 400 voice xxxx

encapsulation dot1Q 400

ip address

no snmp trap link-status


interface FastEthernet0/1

ip address

duplex full

speed 100


and on the switches I have all the ports set up as dot1q trunks with vlan 200 as the native to match the BVI interface.

I am passing multiple vlans across the wireless bridge such like a wired trunk port....


John M.

kka Sat, 11/17/2007 - 10:59
User Badges:

What IOS version are using on the bridges? There were

some bugs in older versions with DHCP not working.

I have an almost identical setup (trunk-bridging,

Cisco router as DHCP server), this works with IOS 12.3(11)JA1.

There is no DHCP-relay necessary.

One thing strange in your router config:

The netmask for your DHCP-pool "ipphone" is,

while on the interface Fa0/0.400 it is

johnminon Mon, 11/19/2007 - 06:50
User Badges:

Version 12.4(3g)JA1 is the IOS I am using...am going to check the bug tool kit

The addressing issue is correct.....that is a typo.....good lookin out!!!!


johnminon Mon, 11/19/2007 - 09:03
User Badges:

Upgraded the IOS to 12.4(10b)JA and it works now. There is no bug on the old IOS....looked for a while.

Thanks for the help


This Discussion