TCL-IVR Script on AS5350XM

Unanswered Question
Nov 14th, 2007

Currently I tried develop TCL-IVR.

During development I use Cisco 2800 as the Voice Gateway. I have already tested that the script can work properly as common IVR.

Now I want to put the script on the production machine (AS5350XM). Unfortunately when I put the script and tested it, the caller cannot hear the greeting from the router and the router cannot get the DTMF input from caller.

Is there any command line on AS5350XM to activate the IVR?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Paolo Bevilacqua Thu, 11/15/2007 - 01:56

Not really.

May be you developed the scripts over analog interfaces and now with ISDN PRI something is different ?

What is the output of "debug voice application media" ?

wahyukurnia Thu, 11/15/2007 - 03:26

On 2800 series I used E1/R2 and on the AS5350 I configure the E1 as the same one.

During debug process, I can see that actually the IVR play the exact file, but the sound can be heard. Do we need specify functionality of the DSP?

Atached below is result for debug coice application media state.

Paolo Bevilacqua Thu, 11/15/2007 - 04:03

Apparently all is OK. Which exact IOS are you using? Can you reload the AS and try again ?

wahyukurnia Thu, 11/15/2007 - 04:07

The IOS version is: c5350-js-mz.124-15.T1.bin

I have reload the AS53 several times, but I still get the same thing.

Paolo Bevilacqua Thu, 11/15/2007 - 04:31

Do you need any feature in T ?

Can you try, for example, latest 12.4 mainline or 12.4(11)XJ4 ?

Paolo Bevilacqua Thu, 11/15/2007 - 05:26

Sorry, I correct myself, indeed you are getting an error:

*Mar 13 11:41:55.362: //33//MSM :/ms_asDone_buginf: callID=0x21, pVdb=0x666E3AA4,

disposition=-4, playFunc=0x61BE78DC,

codec=0xFFFFFFFF=No Codec , vad=0,

mediaType=6, streamAssocID=34



can you try a different file ?

Paolo Bevilacqua Fri, 11/16/2007 - 09:34


same error:

*Mar 13 14:20:09.583: //7//MSM :/ms_asDone_buginf: callID=0x7, pVdb=0x66EDBDB8,

disposition=-4, playFunc=0x61D01748,

codec=0xFFFFFFFF=No Codec , vad=0,

mediaType=6, streamAssocID=8

*Mar 13 14:20:09.583: //7//MSM :/ms_stop_play: mgdTstop at 00:14:04.924 (cause MS_STOP_SETUPFAIL)

I think this means either the file cannot be read, or is invalid format.

wahyukurnia Fri, 11/16/2007 - 18:54

For testing I used audio file originally from Cisco that I downloaded from Software Download TCLWare. When I tested using the same script and audio file on 2800 and AS53, I found different result. On 2800, the prompt can be heard, but on AS53 cannot. When I debug using command "debug voice app media state", I found the different result as well. Please see the detail debug result at the attachment.

In Router 2800:

When play *.au, the result is:

disposition=0, playFunc=0x612A8C68,

codec=0x5=g711ulaw, vad=0,

mediaType=6, streamAssocID=2

In Router AS53:

When play *.au , the result is:

disposition=-4, playFunc=0x6186D2E0,

codec=0xFFFFFFFF=No Codec , vad=0,

mediaType=6, streamAssocID=2

Based on result above:

- Is there any additional command to specify the codec when play audio file?

- Is there any different audio format between 2800, 1751 and AS53?

- What is the right audio format supported by AS53?

I have not found any statement yet in TCL 2.0 guide and AS53 about the right audio format supported for AS53. The document only state the audio format is *.au or *.wav.

Please advice.

Paolo Bevilacqua Sat, 11/17/2007 - 02:17


perhaps, unknown to us, there is some subtle difference in coding that prevents prompts working on the ISR to work on the AS. But as you said, nothing like that is documented.

On the oher hand, the AS is reporting like the file was corrupt, can you try copying it once more, or replace with another ?

What you could try, install the TCL/IVR recorder that I wrote:

and record the prompts natively on the AS53. I the prompts I've prepared do not play, you can do "blind" recording by pressing 2, the a two digits number, start recording, press # at the and. A corresponding file will be created in the "location" directory.

Good luck!

wahyukurnia Sat, 11/17/2007 - 08:26


Many thanks for your great recording application. Unfortunately it only can work properly in ISR router not in AS53 like other application.

AS53 could not recognize DTMF as well, so that we cannot record new prompt (menu #2), and enter the new ID prompt. When I record using ISR router then put the new prompt to be played by AS53, it still has the problem.

Please advice.

Paolo Bevilacqua Sat, 11/17/2007 - 08:31

Sorry, I don't know what could be wrong with the AS53 that prevents it from doing the most basic things. I don't even have one to test.

Perhpas it's matter for the TAC?


This Discussion