voice translation-rule issue

Unanswered Question
Nov 15th, 2007

I have the following voice translation rule to strip a leading 9:


voice translation-rule 1

rule 1 /^9/ //

!

!

voice translation-profile strip

translate called 1

!


It is applied to my dial-peer:


dial-peer voice 800 voip

description Outbound Toll Free to GC

translation-profile outgoing strip

destination-pattern 918[0,4-8][0,4-8]T

voice-class codec 1

session protocol sipv2

session target ipv4:146.82.24.37:5060

dtmf-relay rtp-nte

no vad

!


No matter what I try, it continues to send the leading 9:


Sent:

INVITE sip:[email protected]:5060 SIP/2.0

Via: SIP/2.0/UDP 10.1.50.10:5060;branch=z9hG4bKE2250

From: <sip:10.1.50.10>;tag=1ED4CC-A2D

To: <sip:[email protected]>


What am I missing? This seems so easy and I've done it a million times.


Thanx,

-Tim

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
allan.thomas Thu, 11/15/2007 - 14:37

It appears that you are not forwarding digits and you are certainly stripping digits on the VoIP DP, so the thing to try is initiate a 'debug vpm signal' to see what digits are actually being forwarded when you dial the number and take it from there.


Regards

Allan.

TIMOTHY DAVIDSON Thu, 11/15/2007 - 14:44

Not sure I understand. You can see in the invite that the digits are being forwarded to the SIP gateway. It's just not stripping the leading 9.


-Tim

TIMOTHY DAVIDSON Thu, 11/15/2007 - 14:43

This is 12.4.3e IPVOICE. I also tried it on another router with 12.4(11)T. Same results.


-Tim

Paolo Bevilacqua Thu, 11/15/2007 - 14:48

This is strange indeed, as you said, done a million times.


What "test voice translation-rule 1 918005551234" shows ?

Any chance you have another DP to the same peer ?

TIMOTHY DAVIDSON Thu, 11/15/2007 - 14:54

The translation rule seems to work great:


STA2811#test voice translation-rule 1 918005551234

Matched with rule 1

Original number: 918005551234 Translated number: 18005551234

Original number type: none Translated number type: none

Original number plan: none Translated number plan: none


There are only a couple of dial-peers on this system, and only one to my SIP gateway, so I know it's hitting the right one (I also debugged the dial-peers to make sure).


Hmmm


-Tim

Actions

This Discussion