IVR Script errors in ICM Router logs

Unanswered Question
Nov 15th, 2007

I have recently starting to get several errors in the eventviewer on the Routers in my ICM setup. It says the following : "The script default\xxxxxxxxx excecuted for more than 1000 nodes". What could caus ethis problem. I have not found anything when searching cisco about somthing explaining this behaviour.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Riccardo Bua Fri, 11/16/2007 - 00:20

Hi Patrick,


you most likely have a loop in the script, basically a node gets executed each time the router uses it. Let's say you have a VRU script and a wait two seconds node at the end of it and then the vru script again if the VRU script get's executed 500 times you touched 999 nodes.


Hope this helps your investigation, usually this scenarios happen for announcement or if agents are not available and the queue is building up, the 1000 nodes limits could be modified IF there is a reason and enough resources to attend the additional build up in the queue in the router registry.


Regards,


Riccardo

BarryMcLellan72678 Thu, 11/22/2007 - 09:16

Hello,


To add to this, we had a couple of routing scripts setup to play media files for music on hold using the PM microapp. In the params entry field we did not specify anything assuming 'N' would be the default. What we found was that if you didn't put in the 'N', and the user hit the touchpad on their phone a few times it would invalidate every PM in the call flow. When this happened it looped >999 times because the music would not play while in our queue loop.


Good luck!

Actions

This Discussion