Multilink PPP problem

Unanswered Question
Nov 17th, 2007

Hi Guys,

i got a situation here and hope someone will be able to help me out. Recently i configured a PPP multilink and am facing some issues after that.

Issue 1:

There seems to be lot of input error on multilink interface (150 errors in 40 mins)

Issue 2:

when any of the multilink member interface goes down (all other links are active), am getting packrt drops and request timed out when i ping my other end multi link interface atleast for some 30 sec , after which my response is ok.

About my network

I have connectivity between site A and Site B which consists of five 64 kbps Leased lines bundled together with Multilink PPP

My configuration is shown below

End A

interface multilink 1

ip address x.x.x.x x.x.x.x

ppp multilink fragment-delay 20

ppp multilink interleave

ppp multilink

multilink-group 1

int Ser 2/0

bandwidth 64

no ip address

no ip redirects

no ip proxy-arp

encapsulation ppp

no ip route-cache

no ip mroute-cache

no fair-queue

ppp multilink

multilink-group 1

int Ser 2/1

bandwidth 64

no ip address

no ip redirects

no ip proxy-arp

encapsulation ppp

no ip route-cache

no ip mroute-cache

no fair-queue

ppp multilink

multilink-group 1

int Ser 2/2

bandwidth 64

no ip address

no ip redirects

no ip proxy-arp

encapsulation ppp

no ip route-cache

no ip mroute-cache

no fair-queue

ppp multilink

multilink-group 1

int Ser 2/3

bandwidth 64

no ip address

no ip redirects

no ip proxy-arp

encapsulation ppp

no ip route-cache

no ip mroute-cache

no fair-queue

ppp multilink

multilink-group 1

int Ser 2/4

bandwidth 64

no ip address

no ip redirects

no ip proxy-arp

encapsulation ppp

no ip route-cache

no ip mroute-cache

no fair-queue

ppp multilink

multilink-group 1

End B

interface multilink 1

ip address ip address x.x.x.x x.x.x.x

ppp multilink fragment-delay 20

ppp multilink interleave

ppp multilink

multilink-group 1

interface S 2/0:1

bandwidth 64

no ip address

no ip redirects

no ip proxy-arp

encapsulation ppp

no ip route-cache

no ip mroute-cache

no fair-queue

ppp multilink

multilink-group 1

interface S 2/0:11

bandwidth 64

no ip address

no ip redirects

no ip proxy-arp

encapsulation ppp

no ip route-cache

no ip mroute-cache

no fair-queue

ppp multilink

multilink-group 1

interface S 2/0:25

bandwidth 64

no ip address

no ip redirects

no ip proxy-arp

encapsulation ppp

no ip route-cache

no ip mroute-cache

no fair-queue

ppp multilink

multilink-group 1

interface S 2/0:4

bandwidth 64

no ip address

no ip redirects

no ip proxy-arp

encapsulation ppp

no ip route-cache

no ip mroute-cache

no fair-queue

ppp multilink

multilink-group 1

interface S 2/0:6

bandwidth 64

no ip address

no ip redirects

no ip proxy-arp

encapsulation ppp

no ip route-cache

no ip mroute-cache

no fair-queue

ppp multilink

multilink-group 1

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Sun, 11/18/2007 - 08:04

Hi,

1. Which kind of errors, and do you have errors on physical interfaces ? Send the full show interface if in doubts.

2. do you loose link member frequently enough for this to be a problem? You can try changing the keepalive setting under interface.

sonyscaria Sun, 11/18/2007 - 19:39

pls find the output of show command

END A #sh int multilink 5

Multilink5 is up, line protocol is up

Hardware is multilink group interface

Description: ***Multilink to End B ***

Internet address is 192.26.0.162/30

MTU 1500 bytes, BW 320 Kbit, DLY 100000 usec,

reliability 255/255, txload 2/255, rxload 1/255

Encapsulation PPP, loopback not set

Keepalive set (10 sec)

DTR is pulsed for 2 seconds on reset

LCP Open, multilink Open

Open: IPCP, CDPCP

Last input 00:00:00, output never, output hang never

Last clearing of "show interface" counters 19:55:13

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 2000 bits/sec, 4 packets/sec

5 minute output rate 3000 bits/sec, 4 packets/sec

309478 packets input, 58763590 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

1492 input errors, 0 CRC, 1492 frame, 0 overrun, 0 ignored, 0 abort

290606 packets output, 32728691 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

END A #sh ppp multilink

Multilink5, bundle name is End B

Bundle up for 22:06:31

493 lost fragments, 162050 reordered, 0 unassigned

999 discarded, 0 lost received, 3/255 load

0xAE5E6 received sequence, 0x69F6B sent sequence

Member links: 5 active, 0 inactive (max not set, min not set)

Se2/0, since 20:07:34, last rcvd seq 0AE5E1, 160 weight, 152 frag size

Se2/2, since 20:04:45, last rcvd seq 0AE5E2, 160 weight, 152 frag size

Se2/3, since 20:04:07, last rcvd seq 0AE5E3, 160 weight, 152 frag size

Se2/5, since 20:03:24, last rcvd seq 0AE5E4, 160 weight, 152 frag size

Se2/1, since 19:57:12, last rcvd seq 0AE5E5, 160 weight, 152 frag size

Am getting 1400 input errors in last 19 hours on multilink interface, also less than 100 input errors on member serial interfacs.Also am not loosing any link member.

lgijssel Mon, 11/19/2007 - 01:20

Input errors are often due to line issues or incorrect grounding. You may check the latter yourself. Also, make sure that a single line does cause the majority of the errors. For other bit-error issues you will often need to consult your provider.

The problem with multilink is that losing one fragment renders the whole packet invalid so that it must be retransmitted. Also, multilink is quite cpu-intensive.

You might be better off using HDLC or PPP without multilink encapsulation and equal cost load balancing with OSPF.

regards,

Leo

Actions

This Discussion