3550XL VoIP configuration

Answered Question
Nov 19th, 2007
User Badges:

hi


im using a 3550XL with c3500xl-c3h2s-mz.120-5.WC17.bin IOS version and i tried the standard configurion


switcport mode access

switchport access vlan 20

switchport voice vlan 10


and although it accept the voice vlan , it does nt work . all ports belong only in data vlan .

is there any way to change this?


thanks

Correct Answer by andrew.butterworth about 9 years 4 months ago

Unfortunately the 3500XL (& 2900XL) run IOS 12.0 and must be configured differently from the current range of switches (2950 and up) with regards to Voice VLANs. To enable Voice VLANs like you would on access ports on a 2950 or later you must configure the ports on the 3500XL & 2900XL as trunks. QoS is also not configurable on this platform - the 3524XL-PWR and 3548XL support QoS but it cannot be configured, all other 2900XL & 3500XL don't support QoS.


!!!!!2950 or later typical config

interface FastEthernet0/1

switchport mode access

switchport access vlan 10

switchport voice vlan 100

!


!!!!!3500XL/2900XL Voice VLAN Access port

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 10

switchport voice vlan 100

switchport trunk allowed vlan 1,10,100,1002-1005

!


In both examples above the Access VLAN is 10 and the Voice (Tagged) VLAN is 100, note the configuration differences on the XL series to achieve the same functionality.


The 3548XL has been EOS since July 2002, and was EOL July 2007. The recommended replacement products are now also EOS (2950 & 3550) so you should really look at replacing these with 3560/3750 series switches.


HTH


Andy

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
bkoum Mon, 11/19/2007 - 23:06
User Badges:

hi

i have already read that pdf and many other but the model i use ( cisco WS-C3548-XL) doesnt support mls qos command or voice vlan without trunking the ports... i can see only switchport priority ....command for QoS.

is it the IOS version or the device ?

Correct Answer
andrew.butterworth Tue, 11/20/2007 - 12:56
User Badges:
  • Gold, 750 points or more

Unfortunately the 3500XL (& 2900XL) run IOS 12.0 and must be configured differently from the current range of switches (2950 and up) with regards to Voice VLANs. To enable Voice VLANs like you would on access ports on a 2950 or later you must configure the ports on the 3500XL & 2900XL as trunks. QoS is also not configurable on this platform - the 3524XL-PWR and 3548XL support QoS but it cannot be configured, all other 2900XL & 3500XL don't support QoS.


!!!!!2950 or later typical config

interface FastEthernet0/1

switchport mode access

switchport access vlan 10

switchport voice vlan 100

!


!!!!!3500XL/2900XL Voice VLAN Access port

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 10

switchport voice vlan 100

switchport trunk allowed vlan 1,10,100,1002-1005

!


In both examples above the Access VLAN is 10 and the Voice (Tagged) VLAN is 100, note the configuration differences on the XL series to achieve the same functionality.


The 3548XL has been EOS since July 2002, and was EOL July 2007. The recommended replacement products are now also EOS (2950 & 3550) so you should really look at replacing these with 3560/3750 series switches.


HTH


Andy

Actions

This Discussion