Multiple vlans is not working in 2950 switches

Unanswered Question
Nov 20th, 2007

I have created multiple vlans in my 2950 switch,which is connected to the router and for each vlan we have created subinterfaces

in router,we have shutdown the vlan 1 in switch.But at a time only one vlan is up and other vlans becomes shutdown.but I am not creating the vlans in the database,In sh interface trunk command the trunk ports are also showing.So please suggest us to solve the problem.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Tue, 11/20/2007 - 02:07

Hi Jay

Could you just confirm that

1) You have created the vlans at layer 2 on the 2950 switch

2) You have configured the port connecting to the router as a trunk

3) The router has the correct encapsulations per sub-interface ie. if the vlan is 10

int fa0/0.10

encapsulation dot1q 10

ip address x.x.x.x x.x.x.x

Jon

Anonymous (not verified) Tue, 11/20/2007 - 07:25

andrew.butterworth Tue, 11/20/2007 - 08:47

The 2950 is a layer-2 only switch and can only have a single Layer-3 SVI interface active at any time. What you are seeing is the correct behaviour for this switch (and any layer-2 switch).

Andy

glen.grant Tue, 11/20/2007 - 10:15

You are getting layer2 and 3 confused . The switched virtual interface on the 2950 is to manage the switch only so thus you only need 1 SVI up at a time . On your 2950 create your layer 2 vlan interfaces and then verify with the "show vlan" command . Those layer 2 vlans will then be trunked to your router , all your clients default gateways will then point to the router interface not an address on the 2950 because the 2950 has no routing capability. to create layer 2 , in config mode

vlan XX , then hit enter , this puts you into vlan config mode and you can give a name if you like or whatever other options you would like to add . Verify it shows in the table after with the "show vlan" command.

Actions

This Discussion