SVI vs subinterfaces

Unanswered Question
Nov 20th, 2007

Hello

I have a switch WS-C3560G-24TS (L2-L3 image)

I have a telecom provider equipment connected to the int g0/1 of my switch and carries to my switch different vlans from remote sites (L2L).

The DG IP @ is definedin my switch.

I just want to know what is the difference between cconfiguring SVI or configuring subinterfaces on gig0/1 related to the different vlans carried by the provider

thks in advance for your replies.

config :

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2,3,4

switchport mode trunk

interface Vlan2

ip address 10.2.2.2 255.255.255.0

interface Vlan3

ip address 10.3.3.3 255.255.255.0

interface Vlan4

ip address 10.4.4.4 255.255.255.0

OR

interface GigabitEthernet0/1.2

ip address 10.2.2.2 255.255.255.0

interface GigabitEthernet0/1.3

ip address 10.3.3.3 255.255.255.0

interface GigabitEthernet0/1.4

ip address 10.4.4.4 255.255.255.0

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
andrew.butterworth Tue, 11/20/2007 - 12:33

Logically the differences are STP - i.e. with SVI interfaces there must be a Layer-2 VLAN, with Sub-Interfaces there is no VLAN just a tagged logical port. However I am pretty certain the 2nd configuration you list won't work on a 3560 as you would need to define the VLAN Tag on each subinterface with the command 'encapsulation dot1q x'. I think you can do this on the Catalyst 6500 but not on any of the 'lesser' switches.

HTH

Andy

cco4nsdnet Wed, 11/21/2007 - 00:59

Ok thks Andy.

U're right, i did not fill all the config for the sub interfaces

Anyway, if i understand well the first part of your answer, the only difference is having vlans configured on the switch for the first config and

no no need to have vlans configured for the 2nd config => Ok fort that.

However, my question goes deeper than that.

How can my switch know if there is any problem on the logical link about one of the vlans carried by my provider.

I mean, if i want to implement a second switch with HSRP configured between them for redundancy.

In which case, the line protocol of my SVI or subinterface will be in the status DOWN ?

andrew.butterworth Wed, 11/21/2007 - 01:06

The SVI will remain up as long as at least one Layer-2 port is active & forwarding in the VLAN. This is a common problem on a lot of networks. The only way I can think you could achieve HSRP failover would be with Object Tracking - maybe track reachability of a next-hop on the SP's network.

Are you sure you can actually configure what you posted on a 3560? I just tried it on one here and it doesn't even let me create the subinterfaces.

Andy

cco4nsdnet Wed, 11/21/2007 - 07:23

Hi Andy

In fact, today i configured SVI on the switch.

But just for test, i configured also sub-interface and the switch let me create this sub-interface.

FYI, The IOS Version is 12.2(25)SEB4.

The problem with the objet tracking is that, i don't have a parameter that i can trak as i have just one physical connection which trunk different vlans from my different sites in L2L mode.

I think that the best solution will be implementing a dynamic routing protocol ?!!

Olivier

Actions

This Discussion