ADSL 877W issue. ATM interface keeps dropping

Unanswered Question
Nov 21st, 2007

Hello,

I have a little problem. I configured an ADSL 877W. After it was plugged in, the dialer interface negotiated its IP address ok, but after a few minutes, the atm interface started flapping. It flapped a couple of times, then i lost the IP address. It never picked up an IP address again. I did a couple of debugs, and i couldnt find any errors. The router was replaced with a netgear router, and it worked fine. I replaced the ADSL 877W with a brand new one, and i still experienced the same issue. Please help. My config is as follows:

EASTERN_REGION#sh run

!

ip cef

ip dhcp excluded-address 192.168.10.1 192.168.10.20

!

ip dhcp pool XXX_POOL

network 192.168.10.0 255.255.255.0

dns-server 192.168.10.1

default-router 192.168.10.1

domain-name fmb.co.uk

!

!

ip domain name yourdomain.com

ip name-server yy.yy.yy.yy

ip name-server xx.xx.xx.xx

!

!

crypto pki trustpoint TP-self-signed-978332037

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-978332037

revocation-check none

rsakeypair TP-self-signed-978332037

!

!

crypto isakmp policy 10

hash md5

authentication pre-share

crypto isakmp key uqef23fr923fg address xx.xx.xx.xx

!

!

crypto ipsec transform-set headoffice esp-des esp-md5-hmac

!

crypto map headoffice 10 ipsec-isakmp

set peer xx.xx.xx.xx

set transform-set headoffice

match address 101

!

bridge irb

!

!

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

dsl enable-training-log

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Dot11Radio0

no ip address

no ip route-cache cef

no ip route-cache

!

encryption vlan 1 key 1 size 40bit 0 1234567890 transmit-key

encryption vlan 1 mode wep mandatory

!

ssid FMB_WLAN

vlan 1

authentication open

guest-mode

!

world-mode dot11d country GB both

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

54.0

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

no snmp trap link-status

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

no ip address

ip tcp adjust-mss 1452

bridge-group 1

!

interface Dialer1

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip route-cache flow

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname [email protected]

ppp chap password 0 Change

crypto map headoffice

!

interface BVI1

ip address 192.168.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 102 interface Dialer1 overload

ip nat inside source route-map nonat interface Dialer1 overload

!

access-list 24 permit xx.xx.xx.xx

access-list 24 permit 192.168.0.0 0.0.255.255

access-list 23 permit xx.xx.xx.xx

access-list 23 permit 192.168.0.0 0.0.255.255

access-list 101 permit ip 192.168.10.0 0.0.0.255 192.168.250.0 0.0.0.255

access-list 102 deny ip 192.168.10.0 0.0.0.255 192.168.250.0 0.0.0.255

access-list 102 permit ip 192.168.10.0 0.0.0.255 any

dialer-list 1 protocol ip permit

route-map nonat permit 10

match ip address 102

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

no modem enable

line aux 0

line vty 0 4

access-class 24 in

privilege level 15

password $$$$$$$

login

transport input telnet ssh

!

scheduler max-task-time 5000

end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
CSCO10106129 Wed, 11/21/2007 - 07:41

how is your loop loss/line attenuation

issue a "show dsl interface atm0" and it should give you some info.

also what other debug options have you run?

mitchen Thu, 12/13/2007 - 04:18

If you haven't already, you could try upgrading the ADSL modem firmware on your router. There have been several ADSL inoperability issues with the 877s and certain DSLAMs so Cisco have released a few firmware upgrades.

If you go here, you can see the firware updates available:

ftp://ftp.cisco.com/pub/access/800/

I upgraded firmware on my 877s to 3.0.10 in the past and that resolved similar ADSL "training" issues for me and I see that there have been a couple more firmware updates released since then.

You can look at the readme files from the above FTP site for more details and the full installation process but basically, to upgrade the firmware:

Use "sh dsl int atm0" to identify current firmware

e.g. "FW Version: 2.542"

TFTP the new firmware file (e.g. adsl_alc_20190_3.0.10.bin) into the router's flash.

Rename the new file as "adsl_alc_20190.bin"

Reboot the router for the new firmware to take effect.

When the router comes back up, issue "sh dsl int atm0" again to confirm the router is using the new firmware

e.g. "FW Version: 3.010"

deanhoy Mon, 12/17/2007 - 09:13

Hello

I too own a Cisco 877 adsl router and have noticed that the DSL connection drops about 5 times a day. I have contacted the ISP and they inform me that it is my device that is causing the reset. I have done some checking and tried the atm firmware upgrade but this has not resolved the problem. any ideas?

Modem Status: Showtime (DMTDSL_SHOWTIME)

DSL Mode: ITU G.992.1 (G.DMT) Annex A

Noise Margin: 0.5 dB 22.0 dB

Output Power: 20.0 dBm 12.5 dBm

Attenuation: 48.0 dB 24.0 dB

Activations: 4

Init FW: init_3.0.33_nobist.bin

Operation FW: AMR-3.0.033.bin

FW Source: external

FW Version: 3.0.33

mitchen Mon, 12/17/2007 - 10:06

Here's a few things you could try which might at least help to eliminate some possible causes (I'm assuming you're in the UK!)

1) if you're not already connecting from the master socket (e.g. if you're connecting from an extension), then try connecting via the master socket and disconnecting any other telephony equipment - see if that makes any difference?

2) replace your ADSL microfilter with a good quality "BT approved" one and see if that makes any difference?

3) try connecting to the special BT Test socket (assuming you have an NTE5 type socket) On the face plate of the NTE5 are two screws. If you unscrew them, the bottom half of the BT Master socket can be removed, and you'll see a standard sized BT socket. Connect your microfilter and router to this test socket and see if that makes a difference?

4) if you've got another router (even another vendor's router?) then connect that up and see if it makes a difference?

Hope that helps identify the cause somehow!

jamesgonzo Mon, 12/17/2007 - 10:57

Out of interest does you wireless settings work in your config? I need to confgure my 877w to use wireless and are getting into some problems, so I thought I could work with yous as an example?

Thanks

deanhoy Tue, 12/18/2007 - 01:02

Hello and ty for replying

Yes i do live in the UK.

I will try replacing the ADSL filter as i do have spares.

Also internal phone wiring is not the problem as when i moved into the house i removed all the wiring as it was very old. so from the box on the outside of my house which the bt line come into, it's a 1m distance to my study (aka box room) which terminates into the master socket. and thats it. 1m cable and 1 socket. the rest of the phones in the house use wireless from the base station. Anyways probably a little too much info :)

i have only noticed this drop since upgrading to the cisco 877 from my many netgears.

i do live far from the exchange, about 1.5miles hense the high Attenuation.

Capacity Used: 100% 53%

Noise Margin: 8.0 dB 22.0 dB

Output Power: 20.0 dBm 12.5 dBm

Attenuation: 48.0 dB 24.0 dB

deanhoy Tue, 12/18/2007 - 01:14

update:

i placed a "debug atm state" last night and captured the following.

Dec 18 08:43:55.288: Changing vc 0/38vc-state to ATM_VC_SHUTTING_DOWN

Dec 18 08:43:55.288: Changing vc 0/38vc-state to ATM_VC_NOT_IN_SERVICE

Dec 18 08:43:56.256: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down

Dec 18 08:43:56.256: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di0

Dec 18 08:43:57.255: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to down

Dec 18 08:43:57.287: %LINK-3-UPDOWN: Interface ATM0, changed state to down

Dec 18 08:43:58.287: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to down

Dec 18 08:44:17.154: %LINK-3-UPDOWN: Interface ATM0, changed state to up

Dec 18 08:44:18.153: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to up

Dec 18 08:44:21.072: Changing vc 0/38 vc-state to ATM_VC_ESTABLISHING_VC

Dec 18 08:44:21.072: Changing vc 0/38 vc-state to ATM_VC_NOT_VERIFIED

Dec 18 08:44:21.072: Changing vc 0/38 vc-state to ATM_VC_UP

Dec 18 08:44:22.060: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up

Dec 18 08:44:22.060: %DIALER-6-BIND: Interface Vi2 bound to profile Di0

Dec 18 08:44:28.314: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up

not very detailed but i could setup a syslog server if capturing a more detailed debug is required.

Regards

Dean.

mitchen Tue, 12/18/2007 - 02:16

Yes, I think it would probably be useful to capture as much debug output as you can (don't know if I'd be able to help much with any analysis personally but I'm sure someone on here would!)

There's a utility here for analysing dsl debug output which might be of use to you though:

http://cosi-nms.sourceforge.net/cgitools/dsl_show/

Also, this is perhaps clutching at straws, but I do recall people in the past having stability issues with ADSL and 800 series routers and resolving it by changing "dsl operating-mode auto" under the ATM0 interface to "dsl operating-mode ansi-dmt"

You may have tried that already though if you've browsed through these forums for similar issues. I've never had to do that myself as the firmware upgrade has usually resolved the situation for me!

Also, if you still have one of your old netgear routers handy that you could swap for the 877 temporarily then you could see if it exhibits the same issues? (Just a point of note, I've found the older Cisco 837 routers seemed to be far more stable on ADSL Max connections than the 877s have been, for some reason?)

These sort of issues are usually quite hard to troubleshoot unfortunately - particularly as ISPs normally try to fob off faults on the end user's kit without doing much in the way of detailed investigation. So its just a case of doing as much as you can to eliminate possible causes I think!

deanhoy Tue, 12/18/2007 - 02:37

Hello,

i hadn't actually tied the operating mode adjustment. i have however just changed it from auto to ansi-dmt (please see attached config)

interface ATM0

no ip address

no ip unreachables

ip route-cache flow

logging event subif-link-status

no atm ilmi-keepalive

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode ansi-dmt

end

the interface is now back up and working so i will enable the debugging tonight once i have a syslog server setup.

i will try the utility you refered to and see what results that turns up.

thank you for your reply and i will update soon.

Regards

Dean.

deanhoy Tue, 12/18/2007 - 06:01

update:

since changing the dsl mode i have had 35 resets in 5hrs so i will change the mode back to auto. see show dsl int atm0

Modem Status: Showtime (DMTDSL_SHOWTIME)

DSL Mode: ANSI T1.413

ANSI Issue/rev: 2/1 2/1

Vendor ID: 0x003A 0x0004

Chip ID: C196 (0)

DFE BOM: DFE3.0 Annex A (1)

Capacity Used: 99% 53%

Noise Margin: 14.5 dB 23.0 dB

Output Power: 20.0 dBm 12.5 dBm

Attenuation: 48.0 dB 24.0 dB

Defect Status: None None

Last Fail Code: None

Watchdog Counter: 0x29

Watchdog Resets: 0

Selftest Result: 0x00

Subfunction: 0x00

Interrupts: 8312 (0 spurious)

PHY Access Err: 0

Activations: 35

changing the mode back to auto and it has now negociated the following

DSL Mode: ITU G.992.1 (G.DMT) Annex A

i will monitor this for 5 hrs and report back the number of resets.

Dean.

jamesgonzo Sun, 12/23/2007 - 10:04

Out of interest I take your wireless settings work nicely? I would like to use yours as a template for mine, changing the obvious parts to suit me.

Thanks

Try this one.

Before try delete:

interface Dialer1

interface ATM0

dsl operating-mode auto

dsl enable-training-log

After:

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

no snmp trap link-status

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

interface Dialer0

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip route-cache flow

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname [email protected]

ppp chap password xxxxxxxxxxxxx

ppp pap sent-username [email protected] password xxxxxxxxxxxxxxxxxxxxxx

deanhoy Mon, 01/21/2008 - 05:23

Hello all

I'm finally back home and will now be able to continue this as it is an ongoing problem.

I have the syslog server running so i hope to get some output on the next drop. A quick question on the last post, how would creating a sub interface help with this problem?

Thanks

Dean.

rasoftware Fri, 05/30/2008 - 13:05

Dean,

I have same issues with Virgin net in the uk. Someone has suggested using 3-0-39 but you need a Smart Net to get it.

Jacob Samuel Sat, 06/28/2008 - 00:23

Hi All

I am experiancing a same kind of scenario with my ADSL Link. In my case the Router is Cisco 2621.The CD LED is coming up for a second and goes down... again after few minits repeat the same.

This issue has started once after the Telco cut our link, normal telephone link, by mistake. After they connect the link back it showing this problem, there is no change on the device. Telco saying that there is no problem from their side and they showed the link working using a normal dsl modem.

yup it is workng with dsl modem but when i return to router atm interface the same issue, CD LED comes up and goes down freequently.

i have treid on the second adsl card, which is spare, on the same router, but the same result.

i am attching the router config and debugs

please check... i believe the problem again at the ISP side only they need to reset the Pots.... please correct if i am wrong on my statement and please help me out to fix the problem

regards

Jacob

Paolo Bevilacqua Sat, 06/28/2008 - 04:20

Hi,

Apparently the cut and repair of the line have caused a degradation in quality that the WIC-1ADSL is unable to handle.

You can only try upgrading IOS to see if newer ADSL FW can help. It may, or may not.

The current version should be indicated at the beginning of the training log that you have not included.

taherudin Sun, 07/06/2008 - 13:35

Hello sir

I am new in cisco gear and i like to lurn cisco wher i am working cisco supplyers and we have many customers for cisco 877w ADSL modem will send me configration how to setup i dont have experiance in CLI command or if can send me screen short of SDM setup will be apreciatable

Thanks

Taher

Actions

This Discussion