Problem, configuring Wi-Fi in Cisco851W

Unanswered Question

I need to configure my Cisco851W, using WEP encryption with SSID, which anyone can find in wireless network neigborhood.(with Broadcast SSID in Beacon in terms of Cisco)

I am trying to do this simple thing using Wireless Application.

I input name of SSID,

then mark "Broadcast SSID in Beacon",

no VLAN

input IP address,

then mark Static WEP Key,

input Key

and after clicking apply, I see in the bottom of page my SSID with nothing in the column "Broadcast SSID"

And so, when I am trying to browse wireless networks near me with my notebook, I do not see this SSID.

Is it possible to do such thing with this router?

If the answer is yes, then

What I am doing wrong?

Could you please help me.

Thanks in advance.

Oleg

Below is my config

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.

Current configuration : 6415 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Cek

!

boot-start-marker

boot-end-marker

!

no logging buffered

enable secret xxx

enable password XXX

!

aaa new-model

!

aaa group server radius rad_eap

aaa group server radius rad_mac

aaa group server radius rad_acct

aaa group server radius rad_admin

aaa group server tacacs+ tac_admin

aaa group server radius rad_pmip

aaa group server radius dummy

aaa authentication login eap_methods group rad_eap

aaa authentication login mac_methods local

aaa authorization ipmobile default group rad_pmip

aaa accounting network acct_methods start-stop group rad_acct

!

aaa session-id common

no ip dhcp use vrf connected

ip dhcp excluded-address 172.16.1.100

!

ip dhcp pool HOME

import all

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

dns-server 192.168.1.1 217.10.32.5 217.10.35.5

!

ip dhcp pool wi-fiPool

import all

network 172.16.0.0 255.255.255.0

dns-server 192.168.1.1

default-router 172.16.0.100

!

ip cef

ip domain name XXX.ru

!

crypto pki trustpoint TP-self-signed-1488117618

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1488117618

revocation-check none

rsakeypair TP-self-signed-1488117618

!

crypto pki certificate chain TP-self-signed-1488117618

certificate self-signed 01

30820242

quit

!

!

bridge irb

!

interface FastEthernet0

interface FastEthernet1

interface FastEthernet2

interface FastEthernet3

interface FastEthernet4

description $ETH-WAN$

ip address dhcp client-id FastEthernet4

ip nat outside

ip virtual-reassembly

speed auto

full-duplex

!

interface Virtual-Template1 type serial

ip unnumbered Vlan1

ip nat inside

ip virtual-reassembly

!

interface Dot11Radio0

description Wi-Fi

ip address 172.16.0.100 255.255.255.0

no ip route-cache cef

no ip route-cache

!

broadcast-key change 600

!

!

encryption key 1 size 128bit 0 XXXXXXXXXXX transmit-key

encryption mode wep mandatory

!

encryption vlan 20 mode wep mandatory

!

ssid CiscoSec

!

speed basic-1.0 ...

station-role root

no dot11 extension aironet

!

interface Vlan1

ip address 10.10.10.1 255.255.255.0

ip access-group 102 in

ip nat inside

ip virtual-reassembly

!

interface BVI1

ip address 172.16.1.100 255.255.255.0

ip nat inside

ip virtual-reassembly

!

router rip

redistribute connected

network 10.0.0.0

network 192.168.1.0

!

!

ip http server

ip http access-class 2

ip http authentication local

ip http secure-server

ip nat inside source list 3 interface FastEthernet4 overload

ip nat inside source list 4 interface FastEthernet4 overload

!

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 10.10.11.0 0.0.0.255

radius-server local

user XXXXX nthash 7 135747345E5B17071

!

radius-server attribute 32 include-in-access-req format %h

radius-server vsa send accounting

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

no modem enable

speed 115200

line aux 0

line vty 0 4

access-class 103 in

privilege level 15

password qwerty

transport input telnet ssh

transport output ssh

!

scheduler max-task-time 5000

end

rob.huffman Thu, 11/22/2007 - 09:25

Hi Oleg,

Perhaps this is what you are looking for :)

The command that controls the "Broadcast" of the SSID is "guest mode". Have a look;

guest-mode (SSID configuration mode)

Use the guest-mode SSID configuration mode command to configure the radio interface (for the specified SSID) to support guest mode. Use the no form of the command to disable the guest mode.

[no] guest-mode

The access point can have one guest-mode SSID or none at all. The guest-mode SSID is used in beacon frames and response frames to probe requests that specify the empty or wildcard SSID. If no guest-mode SSID exists, the beacon contains no SSID and probe requests with the wildcard SSID are ignored. Disabling the guest mode makes the networks slightly more secure. Enabling the guest mode helps clients that passively scan (do not transmit) associate with the access point. It also allows clients configured without a SSID to associate.

Examples

This example shows how to set the wireless LAN for the specified SSID into guest mode:

(config-if-ssid)# guest-mode

This example shows how to reset the guest-mode parameter to default values (no broadcast SSID):

(config-if-ssid)# no guest-mode

From this IOS Command doc;

http://www.cisco.com/en/US/products/hw/routers/ps272/products_technical_reference_chapter09186a008022e0e3.html#wp2641711

Hope this helps!

Rob

Thanks a lot, Rob

you point me to the right direction.

Now I can see my SSID in wireless networks list, but I can not connect to it.

When i am trying to connect my notebook waits a couple of seconds, trying to connect and then says smth like that "can't connect to selected network. This network can be out of range. Try to refresh a list of available networks."

Do you have any ideas, how to solve this?

Actions

This Discussion