NTP on WLC2006

Unanswered Question
Nov 22nd, 2007

Hi,

I want to synchronise a WLC2006 with a NTP server. After having set the NTP server IP address with the GUI, the ping operates properly, but the WLC keeps the date and time set manually. The NTP server is connected to the port supporting the dynamic interface carrying the data traffic (that means it is not connected to the port supporting the management and AP interfaces).

The NTP server looks operating properly: a MAR3200 and 2 AP1242 on the other side of the radio link are synchronised with this NTP server. The WLC is running the 4.2.61.0 release.

Do I miss a parameter configuration? Any link is welcome.

Best Regards,

Alain-Claude

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (4 ratings)
Loading.
Richard Atkin Thu, 11/22/2007 - 13:15

Hi,

This is a common problem with WLCs, although one we normally see with RADIUS, not NTP...

Anyway, there is a design requirement whereby any services the WLC needs to contact (RADIUS, SNMP Server, NTP Server, Syslog, etc...) should be connected in such a way that either (a) they are in the same VLAN as the WLC Management Interface, or (b) they are in a VLAN not directly connected to the WLC.

Basically if your NTP server is on a Dynamic Interface, it confuses the hell out of the WLC, which subsequently forwards the traffic out of the wrong interface, and you never see it again, hence your lack of synchronisation. By restricting the location of the NTP to either the Management Subnet, or a VLAN not connected to the WLC (so it will exit via the Mgmt Interface as normal), you avoid this problem, and everything will work as required.

Regards,

Richard

martec_acbarcelo Fri, 11/23/2007 - 00:49

Hi Richard,

Thanks for your answer. I will modify my "Ground" infrastructure et make the try.

Regards,

Alain-Claude

One other comment regarding Daylight Savings Time (in case this affects you, Alain-Claude):

The WLC does not automatically support Daylight Savings Time changeover. Also, there are some specific considerations when setting the timezone field. Please refer to the Cisco field notice 62646:

http://www.cisco.com/en/US/products/ps6308/products_field_notice09186a00807d4058.shtml

Excerpt:

"It is strongly recommended to set WLC for UTC (no offset).

Then configure (off set) from the WLC GUI. This is done via: Commands -> Set Time -> Timezone: set both hours and minutes to 0.

If the WLC is located in a region that does not use DST, such as Arizona, you may set the timezone offset on the WLC, and it will handle the timezone offset correctly.

If the WLC is located in a region that uses DST, during standard time, run with the standard offset, then at the time when daylight rules take effect, manually tell the WLC to set the offset forward. When standard time resumes, manually tell the WLC to set the offset back.

It is strongly recommended, in any case, to configure the WLC to get its time from an NTP server. Note that the NTP does not communicate any timezone offset and/or DST change information. It uses only UTC."

(Please rate helpful posts)

- John

martec_acbarcelo Tue, 12/18/2007 - 09:52

Thanks John. I will take into account when I will again introduce a NTP server in my test bed.

Alain-Claude

martec_acbarcelo Thu, 01/03/2008 - 02:14

Hi,

I have inserted the NTP server in a separate subnet and all look working properly.

Thanks to All for your help.

Happy New Year

Alain-Claude

Actions

This Discussion

 

 

Trending Topics - Security & Network