InterVLAN Traffic - Late Collisions

Unanswered Question
Nov 22nd, 2007
User Badges:

Hi,


I have a PIX515E - IOS7.0(1) and a Catalyst Switch 3560 v12.2. Eth 2 of the PIX was configured with "router on a stick" and it is connected to port 1 of the switch with configs as follows:


PIX:

interface Ethernet2

speed 100

duplex full

no nameif

security-level 100

no ip address

!

interface Ethernet2.1

vlan 1

no nameif

no security-level

no ip address

!

interface Ethernet2.100

vlan 100

nameif dmznet

security-level 0

ip address 192.168.3.254 255.255.255.0

!

interface Ethernet2.101

vlan 101

nameif internalnet

security-level 100

ip address 192.168.4.254 255.255.255.0


SWITCH:

interface GigabitEthernet0/1

description TRNKPIXETH2

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate


The problem is this... when I transfer a file (windows copy n paste) from 192.168.3.1 to 192.168.4.1 it took so long. So I had a look on the interface counters on port 1 of the switch and I noticed that collisions and late collisions were increasing fast. Next, I checked the speed & duplex settings of port 1 of the switch - it was on auto and it is only getting half duplex 100Mbps which is a mismatch from the PIX which is full duplex 100Mbps. So what I did was I configured port 1 with full duplex 100Mbps to match with the PIX but the switch can't connect anymore to the PIX (ping timed out). So now, I reverted back port 1 of the switch to half duplex 100Mbps and made eth2 of the PIX to half duplex 100Mbps and with that everything works - i got no late collisions.


My question now is why does this set up only works for half duplex? Can I use full duplex at all?


Your clarifications on this issue will be greatly appreciated.


thanks in advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Thu, 11/22/2007 - 05:18
User Badges:
  • Purple, 4500 points or more

You should be able to use full duplex . The original behavior was correct , you had a device hardcode at 100/full and a switchport at auto .in this case the switch will default to 100/half which is correct because the other end is not auto also so it cannot sense the duplex information . My only thought on your connection is maybe the switch you are using is running mdix which only works in the auto position and when you try to hardcode it would shut it off . Is it astraight thru or crossover cable ? If a straight thru try a crossover and then try hardcoding or get them to set the pix as auto and the switchport as auto and I bet it will negotiate 100/full just fine . Most cisco devices now do not need to be hardcoded and will negotiate speed and duplex just fine on their own . A lot of people got this principal of hardcoding the links back in the earlier years when they did have some issues with the "autonegotiation process and old ideas die hard. There stil can be some rare issues but it is usually between a switch and a old end user device with outdated drivers or some old Sun boxes...

Actions

This Discussion