EIGRP in GRE Tunnel and recursive routing

Unanswered Question
Nov 23rd, 2007

Hi All.

Scheme:

-------

Remote branches connected to main site via Layer2 connection (primary) and Layer3 IP MPLS network connection (backup).

Primary connections are collected on one router while backup to another.

Task and problem:

------------------

I'm trying to setup EIGRP for this scheme

For some unknown reasons Tun33 goes down on the main site.

%TUN-5-RECURDOWN: Tunnel33 temporarily disabled due to recursive routing

I've tried to completely disable all possibilities for announcing Tun IP's

BRANCH-33 configuration

------------------------

interface Tunnel33

description << IP MPLS >>

ip address 172.22.1.26 255.255.255.252

tunnel source 172.26.0.26

tunnel destination 192.168.255.2

end

ip route 192.168.255.2 255.255.255.255 172.26.0.25

! Static route to tun33 dest

router eigrp 300

redistribute connected

network 172.22.1.24 0.0.0.3

distribute-list prefix REDISTR-EIGRP out

no auto-summary

neighbor 172.22.1.25 Tunnel33

ip prefix-list REDISTR-EIGRP

seq 1 permit 10.0.176.0/27

seq 2 permit 10.129.176.0/27

seq 3 deny 172.22.1.24/30

MAIN SITE CONFIGURATION

-------------------------

interface Tunnel33

description << IP MPLS >>

ip address 172.22.1.25 255.255.255.252

tunnel source 192.168.255.2

tunnel destination 172.26.0.26

end

ip route 172.26.0.0 255.255.255.0 192.168.255.1 tag 333 name IP_MPLS

router eigrp 300

network 172.22.1.24 0.0.0.3

distribute-list prefix DENY-TUN-REDISR-EIGRP out

no auto-summary

neighbor 172.22.1.26 Tunnel33

ip prefix-list DENY-TUN-REDISR-EIGRP seq 1 deny 172.22.1.24/30

ip prefix-list DENY-TUN-REDISR-EIGRP seq 2 deny 172.26.0.24/30

ip prefix-list DENY-TUN-REDISR-EIGRP seq 3 deny 192.168.255.0/30

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
jarredtaylor Fri, 11/23/2007 - 04:39

Maxim,

I think your main site router is learning a more specific route to the tunnel destination (172.26.0.26) via EIGRP over the tunnel. I assume the network 172.26.0.24/30 is directly connected to the branch router. Rather than denying the advertisement of that prefix from the main site, you should instead be denying it from the branch. Try adding 'seq 4 deny 172.26.0.24/30' to the REDISTR-EIGRP prefix list on the branch router.

HTH

Jarred

MaximBudyonny Fri, 11/23/2007 - 05:01

Thank you Jarred.

You reply was very helpful.

But the root of the issue was just a typo in cisco config. :-(

Instead of "distribute-list prefix REDISTR-EIGRP out" I typed "distribute-list REDISTR-EIGRP out" while in the forum post I've wrote correct command.

Copy-Paste is really great technic! :-)

deb ip eigrp 300 helps me to find this error.

I've seen that for some reasons branch router advertises some networks while it must not be.

Problem is solved.

I'm greatly appreciate to you. Your propose is very interesting.

Actions

This Discussion