AP and DHCP problem

Unanswered Question
Nov 23rd, 2007
User Badges:

I have a router with 2 subinterfaces.

interface GigabitEthernet0/0.1

encapsulation dot1Q 20 native

ip address 130.130.130.1 255.255.255.0

ip helper-address 192.168.1.5

interface GigabitEthernet0/0.99

encapsulation dot1Q 99

ip address 120.120.120.43 255.255.255.248

ip helper-address 192.168.1.5

I have a 3750 level 2 with this vlans.


interface Vlan99

ip address 120.120.120.41 255.255.255.248

ip helper-address 192.168.1.5

interface Vlan20

ip address 130.130.130.10 255.255.255.0

ip helper-address 192.168.1.5

I have the AP is connected to a port in the 3750


interface FastEthernet1/0/47

switchport trunk encapsulation dot1q

switchport trunk native vlan 99

switchport trunk allowed vlan 20,99

switchport mode trunk

Users connected to the 3750 ports vlan 20 can get IP from the range 130.xx

I want users connected to the access point to have IP's from range vlan20 (130.xx) (the same that the users connected to the 3750)

HOw can i do it?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Atkin Fri, 11/23/2007 - 09:50
User Badges:
  • Silver, 250 points or more

AP Config will basically look like this...




dot11 ssid mywifi

<>

vlan 20

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 20 <>

!

ssid mywifi

!

short-slot-time

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

channel 2437

station-role root access

!

interface Dot11Radio0.99

encapsulation dot1Q 99 native

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.20

encapsulation dot1Q 20

no ip route-cache

bridge-group 20

bridge-group 20 subscriber-loop-control

bridge-group 20 block-unknown-source

no bridge-group 20 source-learning

no bridge-group 20 unicast-flooding

bridge-group 20 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface FastEthernet0.99

encapsulation dot1Q 99 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface FastEthernet0.20

encapsulation dot1Q 20

no ip route-cache

bridge-group 20

no bridge-group 20 source-learning

bridge-group 20 spanning-disabled

!

interface BVI1

ip address <>

no ip route-cache

!

ip default-gateway <>

hernanseijas Fri, 11/23/2007 - 10:14
User Badges:

I think something is wrong in the switch config because users that connect to the AP can not get an IP..

Thanks

Richard Atkin Fri, 11/23/2007 - 10:22
User Badges:
  • Silver, 250 points or more

From the little that's there, the switch config looks fine.

Actions

This Discussion