Multicast routing using 6509 and 2800

Unanswered Question
Nov 23rd, 2007

I hope someone can help with this. I have a 2800 receiving multicast feeds off of a VLAN10 with sparse-dense-mode enabled. I have a VLAN1 with sparse-dense-mode enabled that's on the same 2800 router and it is connected to a VLAN1 (using L2 link) on a 6509 (this VLAN1 is configured with 8 ports) with no sparse-dense-mode configured. Multicast streams are being picked up on the clients connected to VLAN1 on the 6509 when sparse-dense-mode is not enabled but as soon as I enter the "ip pim sparse-dense-mode" on the VLAN1 on the 6509, the clients connected on the VLAN1 stop receiving the streams. The reason i need to enable the sparse-dense-mode on the VLAN1 on the 6509 is that I am preparing to route the stream to another network - otherwise, i would leave it disabled. The routing seems fairly simple and snooping is enabled on both VLANs but i cannot get this to function properly. Does anyone have an answer? The 6509 is running IOS.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
wochanda Fri, 11/23/2007 - 17:03

Try making sure the 2800 is elected DR on the segment with this command:

interface gig0/1

ip pim dr-priority 10

This will ensure the 2800 is responsible for delivering the streams to Vlan 1.

smartcorridors Mon, 11/26/2007 - 14:02

I will ask for the dr-priority to be set on the 2800. Will disabling IGMP snooping or PIM snooping also correct this problem.

Exerpt from

To use PIM snooping, you must enable IGMP snooping on the Catalyst 6500 series switch. IGMP snooping restricts multicast traffic that exits through the LAN ports to which hosts are connected. IGMP snooping does not restrict traffic that exits through the LAN ports to which one or more multicast routers are connected.


This Discussion