Frame relay QoS question

Unanswered Question
Nov 23rd, 2007

Hello--

I'm running VOIP over a frame-relay WAN and have configured QoS on all routers to prioritize voice traffic. It seems to be working, but I have some questions about the configuration. Setup is a main corporate site connected to 6 remote sites via a single T1 into a frame cloud. For redundancy, each remote site has an additional PVC to a secondary corporate office, which has a point-point T1 back to the main office. Remote offices are very small, with 3-6 users each. Routing protocol is EIGRP. Below are the relevant pieces of the QoS configuration. VOIP switches at the corporate network are all on a dedicated subnet. I left off the configuration for the redundant PVCs.

________________________

MAIN CORP ROUTER

class-map match-all voice-traffic

match access-group 150

access-list 150 permit udp 10.1.4.0 0.0.3.255 any

policy-map frame-policy

class voice-traffic

priority 192

class class-default

fair-queue

map-class frame-relay voip

interface Serial0/0/0

no ip address

service-policy output frame-policy

encapsulation frame-relay IETF

service-module t1 remote-alarm-enable

frame-relay lmi-type ansi

(All PVCs to remote sites are configured under this interface, all are point-point).

REMOTE OFFICE ROUTER (all are configured similarly)

class-map match-all voice-traffic

match access-group 150

access-list 150 permit udp any 10.1.4.0 0.0.3.255

policy-map voice-policy

class voice-traffic

priority 192

class class-default

fair-queue

interface Serial0

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type ansi

service-policy output voice-policy

map-class frame-relay voip

________________________

These configurations came from information document 12156. My questions are:

The policy map allows for 192K of bandwidth for voice (all PVCs are 256K minCIR and normally run well above that). When this is applied to the main interface (s0/0/0) at the corp router, does this mean that 192K is allocated for each PVC or for the entire interface (there are 6 PVCs configured under this interface)?

What is the function of the map-class frame-relay command? It doesn't seem to be applied anywhere.

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
jarredtaylor Sat, 11/24/2007 - 06:22

Bruce,

Your current configuration is allocating 192k across the entire interface...not at the PVC level.

Frame-relay map-classes are used in conjunction with frame-relay traffic shaping. Traffic shaping is necessary to provide QoS on frame interfaces when there are mismatches between CIR and port speed or when there are mismatches between local and remote port speeds.

The issue in your case is that while you are allocating priority BW outbound on the physical interface you are not accounting for the fact that this voice traffic might still be getting marked 'discard eligible' within the frame cloud. In a frame network, all traffic above minCIR is marked discard eligible. Any voice packet that falls into this category can (and will depending on congestion) be dropped. This is not good for voice.

The current recommendation for proper voice QoS on frame circuits is to use map-classes to configure CIR=minCIR and be=0 so traffic will never burst above the guaranteed rate. Your service-policy above will be configured within this map-class as well (with the BW for voice adjusted specifically for each site). The implication, of course, is that your remote sites will then be capped at 256k.

It's hard to recommend this if you say everything is working fine now. I suspect that is due to the fact that the congestion point is outbound on your corp router (where you have applied physical interface QoS) and there is little congestion on your provider's frame network. I'm just relaying info from my experience and from the design guides.

HTH,

Jarred

bsternfield Mon, 11/26/2007 - 09:53

Jarred--

Thanks for the reply. I've just been testing the phones at the moment, so it's hard to know how things will perform when they're in full use.

If I understand it correctly, under the map-class frame-relay command I configure cir = 256 (minCIR is 256), configure the service-policy with service-policy output NAME, and then apply that named policy to the individual PVC?

With this configuration, should I keep the existing Q0S configuration on the physical interface as well?

Thanks.

jarredtaylor Mon, 11/26/2007 - 11:13

Bruce,

Everything you mentioned regarding the map-class is correct. With regards to the application of the policy you actually have two options. If all of the remote sites are identical regarding the frame-relay parameters AND the voice requirements (i.e. identical number of phones etc.) then you can apply the map-class on the physical interface. In that case each PVC on that physical interface will inherit the config. If the sites are not identical then you will need to create individual map-classes and apply them to the appropriate PVC's.

One thing to remember is that in order to use map-classes you will need to enable 'frame-relay traffic-shaping' on the physical interface. After doing so, and after applying the map-classes (in either fashion), you will no longer need the existing QoS policy on the physical interface.

You can reuse the existing QoS policy in the map-class(es) if each site requires 192kbps of priority bandwidth for voice. If not, you will need to adjust that policy for each of the site's requirements.

HTH,

Jarred

bsternfield Tue, 11/27/2007 - 20:21

Jarred--

Thanks for your help. I'll configure it this week and test it out.

--bruce

Actions

This Discussion