cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
494
Views
4
Helpful
5
Replies

Design problem

r_cevat001
Level 1
Level 1

i have 5- 2960 switches how can connect them to a router and which model should i use the 1800 series or 2800 series to make these switches talk to each orther . i'm using a video cameras so there is alot of bandwith.

Thanks all

1 Accepted Solution

Accepted Solutions

If you want multiple VLANs on your access switches then you must use trunks (or multiple uplinks each on a different VLAN - not very efficient). For VLAN's you can either use VTP (not recommended) or statically define them on each switch (preferred). If you only have one layer-3 switch there is no need for a routing protocol as it doesn't acheive anything as a routing protocol only comes into play when there are multiple routers.

L3 switch - 3750:

ip routing

ip multicast-routing

!

vtp mode transparent

!

vlan 10

vlan 11

vlan 20

vlan 21

vlan 100

vlan 200

!

interface GigabitEthernet1/0/1

description to 2960-1

switchport trunk encapsulation dot1q

switchport trunk native vlan 100

switchport trunk allowed vlan 10-11

switchport mode trunk

switchport nonegotiate

!

interface GigabitEthernet1/0/2

description to 2960-2

switchport trunk encapsulation dot1q

switchport trunk native vlan 200

switchport trunk allowed vlan 20-21

switchport mode trunk

switchport nonegotiate

!

interface vlan 10

description 2960-VLAN-10

ip address 10.10.10.254 255.255.255.0

ip pim sparse-mode

!

interface vlan 11

description 2960-VLAN-11

ip address 10.10.11.254 255.255.255.0

ip pim sparse-mode

!

interface vlan 20

description 2960-VLAN-20

ip address 10.10.20.254 255.255.255.0

ip pim sparse-mode

!

interface vlan 21

description 2960-VLAN-21

ip address 10.10.21.254 255.255.255.0

ip pim sparse-mode

!

!!!!!! 2960-1 !!!!!!

!

vtp mode transparent

!

vlan 10

vlan 11

vlan 100

!

interface GigabitEthernet1/0/1

description Uplink to 3750

switchport trunk encapsulation dot1q

switchport trunk native vlan 100

switchport trunk allowed vlan 10-11

switchport mode trunk

switchport nonegotiate

!

interface vlan 10

description management

ip address 10.10.10.250 255.255.255.0

!

ip default-gateway 10.10.10.254

!

This would get you going. It gets a bit more complicated if you introduce additional layer-3 devices as they need to 'tell' each other about routes etc.

Andy

View solution in original post

5 Replies 5

williamsdo
Level 3
Level 3

Hi, I would connect the switches together through the gigabit ports for high bandwidth, i would trunk these port from switch to switch you can remove any vlan traffic you dont want to cross the trunk link. Connect the first switch to your router to route traffic to other network segments. I would go with the 1841 router you have two WIC card slots and multible ethernet ports if you like to connect all your switches directly into the router.

Hi thank you for answering my inquiry. there are some issues remaining.

1- i need more thatn 100 Mbps between the switch and the router (i have video streams)

is it possible to have a 1 gigabit between the router and the switch ?

2- is there any documentation with detailed diagrams showing how to connect switch to switch and switch to router

3- Is it possible to connect the switch uplink to the router

that will be all for now

thank you William

I would suggest using a Layer-3 switch to route between the VLAN's instead of a router if the traffic rate will be high. A Catalyst 3560 or 3750 would be ideal, however for redundancy I would probably install two and connect each 2960 back to each one. Have a read of the design guides for campus networks on the SRND page:

http://www.cisco.com/go/srnd

Andy

Dear nady

thank you for your reply.

ok, lets say that i have 5 X 2960 each one is a separate VLAN

and i don't (lets assume ) redundancy.

can you give me a complete setup of these 2960 switches and L3 switch.

things like

1-vlan definition

2-routing (ospf)

3-multicast routing

4- ip addressing

the necessary things to make ip routing between vlans possible

do i need trunking too. and what about the uplinks ?

sorry for asking too much

thank again andy

If you want multiple VLANs on your access switches then you must use trunks (or multiple uplinks each on a different VLAN - not very efficient). For VLAN's you can either use VTP (not recommended) or statically define them on each switch (preferred). If you only have one layer-3 switch there is no need for a routing protocol as it doesn't acheive anything as a routing protocol only comes into play when there are multiple routers.

L3 switch - 3750:

ip routing

ip multicast-routing

!

vtp mode transparent

!

vlan 10

vlan 11

vlan 20

vlan 21

vlan 100

vlan 200

!

interface GigabitEthernet1/0/1

description to 2960-1

switchport trunk encapsulation dot1q

switchport trunk native vlan 100

switchport trunk allowed vlan 10-11

switchport mode trunk

switchport nonegotiate

!

interface GigabitEthernet1/0/2

description to 2960-2

switchport trunk encapsulation dot1q

switchport trunk native vlan 200

switchport trunk allowed vlan 20-21

switchport mode trunk

switchport nonegotiate

!

interface vlan 10

description 2960-VLAN-10

ip address 10.10.10.254 255.255.255.0

ip pim sparse-mode

!

interface vlan 11

description 2960-VLAN-11

ip address 10.10.11.254 255.255.255.0

ip pim sparse-mode

!

interface vlan 20

description 2960-VLAN-20

ip address 10.10.20.254 255.255.255.0

ip pim sparse-mode

!

interface vlan 21

description 2960-VLAN-21

ip address 10.10.21.254 255.255.255.0

ip pim sparse-mode

!

!!!!!! 2960-1 !!!!!!

!

vtp mode transparent

!

vlan 10

vlan 11

vlan 100

!

interface GigabitEthernet1/0/1

description Uplink to 3750

switchport trunk encapsulation dot1q

switchport trunk native vlan 100

switchport trunk allowed vlan 10-11

switchport mode trunk

switchport nonegotiate

!

interface vlan 10

description management

ip address 10.10.10.250 255.255.255.0

!

ip default-gateway 10.10.10.254

!

This would get you going. It gets a bit more complicated if you introduce additional layer-3 devices as they need to 'tell' each other about routes etc.

Andy

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: