7971 time and locale problems ccme4.2

Answered Question
Nov 25th, 2007
User Badges:

Hi


I am having a little problems with 7970 and 71 phones on a 2801 with ccme4.2

I have 7941 phones on the system with correct time and danish localisation.

When i connect a 7971 phone, the time is one hour behind and the localisation stays on the builtin english.


Any ideas ??


Correct Answer by paolo bevilacqua about 9 years 8 months ago

Yes, the phones tend to keep to locale once successfully loaded.

Go ahead and try the most powerful reset sequence:

poweron with # as for the other. Then the sequence is: 3491672850*#

If that fails I would try IOS XJ4.


Good luck!



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.7 (3 ratings)
Loading.
paolo bevilacqua Sun, 11/25/2007 - 07:38
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


your 7971 isn't picking the locale. If you enable "debug tftp events" and "term mon" when you reset the phone, you will see that is looking for a certain file in a directory according to you contry and language. You need to make sure that this file is available with the "tftp-server xxx alias yyyy" where yyyy is the path the phone is looking for.


After you've fixed the above, if still the time problem please specify which exact IOS and FW the phone is running.


Hope this helps, please rate post if it does!

pbuch Sun, 11/25/2007 - 07:47
User Badges:

Thanks for the fast reply :-)


I have a


tftp-server flash:dk/dk-td-sccp.jar alias Danish_Denmark/td-sccp.jar

And

user-locale DK

user-locale 1 DK

user-locale 2 DK

user-locale 3 DK

user-locale 4 DK

network-locale DK

network-locale 1 DK

network-locale 2 DK

network-locale 3 DK

network-locale 4 DK


in the config, and have tried "debug tftp events"

The phone dosent even ask for the file.


Phone firmware is SCCP70.8-2-2SR2S

IOS c2801-ipvoicek9-mz.124-11.XW2.bin



paolo bevilacqua Sun, 11/25/2007 - 07:54
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Ok, can you upgrade phone FW to 8.2(2)SR4S and IOS to XW4 ? That should fix the time problem.


Then you have to look again into which files the phone is requesting, if nothing comes out for the Danish locale, you might need to work on this as a possible bug with the TAC.


pbuch Sun, 11/25/2007 - 08:07
User Badges:

XW4 is not available for the 2801 that i am running on.

I will try 8.2(2)SR4S for the phones.

tomorrow :-)

Thanks for the fast reply


paolo bevilacqua Sun, 11/25/2007 - 08:24
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

True, apparently XW2 is the latest you can use for CME 4.2.

But, if you don't need new features in 4.2, suggest you try 12.4(11)XJ4 (CME 4.1) that is stable, except for a memory leak that manifest itself only under certain conditions (and may exist as well in XW).


Good luck!

pbuch Sun, 11/25/2007 - 08:50
User Badges:

Just tried SCCP70.8-2-2SR4S on the phones.

No change, it dosent try to read the locale file.

Is 8-3-3SR2S a possible solution or do i have to go back on 12.4(11)XJ4 and CME4.1 tomorrow.

Looks like CME4.2 is still to "wet" to use.


Thanks

paolo bevilacqua Sun, 11/25/2007 - 09:02
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Peter, I've tried "user-locale DK" on one of my XJ4 equipped systems, it correctly requests the locale, of course I didn't verified the accuracy of translations :)


Nov 25 17:59:24.069 CET: TFTP: Looking for SEP000F8F28DAD4.cnf.xml

Nov 25 17:59:27.733 CET: TFTP: Opened system:/its/XMLDefault7970.cnf.xml, fd 1, size 1069 for process 199

Nov 25 17:59:27.737 CET: TFTP: Finished system:/its/XMLDefault7970.cnf.xml, time 00:00:00 for process 199

Nov 25 17:59:28.645 CET: TFTP: Looking for Danish_Denmark/td-sccp.jar


If that doesn't work for you, please try the reset sequence on the phone, press # while powering on, release when line button flash in a pattern, then press 12345678*0#, that will force a complete reset. Make sure you have term70.defaults.loads in flash and tftp config.


No need for FW 8.3.x, as far as I know it still has many bugs :(

pbuch Sun, 11/25/2007 - 09:20
User Badges:

Tried complete reset.

Tried 8-3-3-SR2, gave me the new logo and some old bugs :-(

Impressive lack off testing !!




paolo bevilacqua Sun, 11/25/2007 - 09:28
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Indeed. Try this: set a different locale, reset the phone. Set DK again, reset.

At some point the request must be produced just like the 7970 I tried.

pbuch Sun, 11/25/2007 - 10:03
User Badges:

Tried that, no result.

Tried the same with a 7941, changing to DE and back to KK, no problems.

Tried a total reset of a 7941.

Comes up with the requested locale every time.

Seems like a problem with 7970/71.

I have a 2811, could try with XW3 on that.

Guess that the phone will keep the locale once loaded.


Thanks so far



Correct Answer
paolo bevilacqua Sun, 11/25/2007 - 10:14
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Yes, the phones tend to keep to locale once successfully loaded.

Go ahead and try the most powerful reset sequence:

poweron with # as for the other. Then the sequence is: 3491672850*#

If that fails I would try IOS XJ4.


Good luck!



pbuch Mon, 11/26/2007 - 00:23
User Badges:

Just switched to an 2811 where XJ3 is available. Solved both problems :-)

Strange that XJ3 or XJ4 is not available for 2801 ???

I have 3 x 2801 that are to be delivered this week. The locale problem can be solved via the 2811, but the clock is still 1 hour behind :-(


Actions

This Discussion