Vlan slowness?

Unanswered Question
Nov 26th, 2007

Hi experts,

We have a core switch 6500 with vlan 10 & vlan 20. Both vlans are set to auto-auto (speed/duplex). We noticed that when we connect a PC on vlan 10 & transfer a file say 1gb. The rate is between 30-40mb per sec, so it's fast enough. But when we connect to those port belonging to vlan 20, the rate is about between 4-6mb per sec. Thats a large diference!

checked all settings are same except of course for the ip, subnets....etc.

After we adjusted the the ports belonging to vlan 20 to Full-duplex, 1000Mb/s, the issue was resolved.

Any explanation on this?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
guruprasadr Mon, 11/26/2007 - 19:52

HI, [Do Rate if Helps]

Whether the PC / Equipment connected to the VLAN10 and VLAN20 are same ?

VLAN10 connected with PC ==>> Since the Duplex and Speed set as auto/auto it negotiates Automatically.

VLAN20 connected with Some Equipment (not PC) ==>> based on the Equipment Feature and negotiation capability it reacts.

Pls find the attachment (.doc) for the Valid Speed and Duplex Configuration Table.

Do Rate if HELPS

Best Regards,

Guru Prasad R

redrobish Mon, 11/26/2007 - 20:50

Actually the results above were done using only 1 laptop. So when we adjusted the speed/duplex manually in the switch, the speed changes!

How can we make the ports on vlan 20 detect whatever the device is plugged in it?

When it sets to auto, according to the doc, should be according to the nic config. But how come it doesn't?

thanks for replying.

guruprasadr Mon, 11/26/2007 - 21:12


Yes, based on the Client Connected, the Switch negotiates the Speed / Duplex Setting.

I am not sure what's happening at the VLAN20 and if you could check the #show vlan status for VLAN20 and even enable debug command output to see for any occurance of errrors.


Best Regards,

Guru Prasad R

redrobish Tue, 11/27/2007 - 23:46

Thanks Guru Prasad R

Made some testing...

I plugged a pc on both vlans (same pc) then check the"sho int status";

Gi2/37 connected 10 a-full a-1000 10/100/1000BaseT

Gi2/38 connected 20 a-full a-1000 10/100/1000BaseT

Both give a-full,a-1000...but the port on vlan 20 still is slow.

Then when manually set to full;

Gi2/38 connected 20 full 1000 10/100/1000BaseT

which give me exactly the same performance on vlan 10. strange isn't it?

And the only diff bet them is the "ip helper-address" command. Any relevance on this command?



interface Vlan20

description Vlan 20

ip address y.y.y.y

ip helper-address x.x.x.x

glbp 1 ip y.y.y.y

glbp 1 priority 120

glbp 1 preempt

glbp 1 load-balancing host-dependent

glbp 1 authentication text cisco


interface Vlan10

description Vlan 10

ip address x.x.x.x

glbp 1 ip x.x.x.x

glbp 1 priority 120

glbp 1 preempt

glbp 1 load-balancing host-dependent

glbp 1 authentication text cisco


cannot see any errors on debug! Also tried on diff ports.


guruprasadr Wed, 11/28/2007 - 02:22

HI, [Pls Rate if HELPS]

Could you please try by Delete of VLAN20 and re-create the same !

Could be a possible workaround:


1. Follow as said above

2. Try upgrading the IOS

4. Enable "debug all" commands ==>Make Sure after the investigation the command is Turned OFF, becoz the possibility of Router CPU will go High.

3. At Last, Check with the Vendor for any Hardware issues.


Best Regards,

Guru Prasad R

redrobish Wed, 11/28/2007 - 16:01

Thanks Guru, will do your recommendations...

@ nambi qct

your request is already posted.


guruprasadr Wed, 11/28/2007 - 23:27


Thanks for the Update and keep us informed once its worked.


Best Regards,

Guru Prasad R


This Discussion