AS5400 problem

Unanswered Question
Nov 27th, 2007


I am sending call from a Nextone SBC to an AS5400. The AS5400 is routing the call but not putting any CDN into the ISDN setup message even though the incoming invite has the TO header populated with the number

I compared a good call to a bad and what I did notice is that the bad calls TO header looks like this coming into the 5400

To: 011861085208666<sip:[email protected]:5060>

A good call looks like this

To:<sip:[email protected]:5060>

Could the 5400 have a problem with the double format ? Has anybody seen this before ?

Here is the trace from the 5400 and you notice the CDN field is not populated in the outgoing ISDN setup.


INVITE sip:[email protected] SIP/2.0Max-Forwards: 69Session-Expires: 3600;Refresher=uacSupported: timer, 100relTo: 011861085208666 <sip:[email protected]:5060>From: .2127962106. <sip:[email protected]>;tag=3405179539-136721Call-ID: [email protected]: 1 INVITEAllow: INVITE, BYE, OPTIONS, CANCEL, ACK, REGISTER, NOTIFY, INFO, REFER, SUBSCRIBE, PRACK, UPDATEVia: SIP/2.0/UDP;branch=z9hG4bKb65d5ae8d1e40a74ebd594e0e6e1e0a7Contact: <sip:[email protected]:5060>Call-Info: <sip:>;method="NOTIFY;Event=telephone-event;Duration=1000"Content-Type: application/sdpContent-Length: 195v=0o=NTSBC1 2147483647 2110921806 IN IP4 callc=IN IP4 0m=audio 11810 RTP/AVP 0 18 4 2 2a=fmtp:18 annexb=noa=rtpmap:2 G726-32/8000a=ptime:20

Nov 27 19:12:19.100: ISDN Se1/0:28:23 Q931: Applying typeplan for sw-type 0xD is 0x2 0x1, Calling num 2127962106

Nov 27 19:12:19.100: ISDN Se1/0:28:23 Q931: Applying typeplan for sw-type 0xD is 0x0 0x0, Called num

Nov 27 19:12:19.100: ISDN Se1/0:28:23 Q931: TX -> SETUP pd = 8 callref = 0x56F6

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98397

Exclusive, Channel 23

Calling Party Number i = 0x2180, '2127962106'

Plan:ISDN, Type:National

Called Party Number i = 0x80

Plan:Unknown, Type:Unknown

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
kyleeot75 Tue, 11/27/2007 - 17:12

There is a space

That was a typo

Here is what my dial peer looks like. Can figure out why the 5400 is not translating this tothe ISDN side and sending a NULL CDN to my gateway

dial-peer voice 28 pots

destination-pattern 011861085208666

port 1/0:28:D

kyleeot75 Wed, 11/28/2007 - 08:50

nothing shows up on the degub ccsip error or debug isdn q931 error

The thing is this TO header format is being sent out to a SIP peering provider of mine and they are not having an issue with it. Only the 5400. It does not populate a CDN parameter in the ISDN setup message to my PSTN switch

kyleeot75 Wed, 11/28/2007 - 13:30

I found the issue

This is what my dial peer looked like

dial-peer voice 28 pots


destination-pattern 011861085208666

port 1/0:28:D

Here is what is looks like now

dial-peer voice 28 pots


destination-pattern 0118610

port 1/0:28:D

Now the call works ! ?? The CDN is being placed into the ISDN setup properly

Bug ?

Is there a digit timer command I am missing here ?

Cisco IOS Software, 5400 Software (C5400-IS-M), Version 12.4(16), RELEASE SOFTWARE (fc1)

Paolo Bevilacqua Wed, 11/28/2007 - 18:42

Well, pots DP by default absorbs digits matched in destination-pattern, so configured like it is now, it should send 85208666 as called number.

This behavior can changed with "forward-digits" and "digit-strip" commands.

Hope this helps, please rate post if it does!


This Discussion