WAN problem with 857W

Unanswered Question
Nov 28th, 2007

Hi, I can connect to my ISP (Telia, Sweden), but I don't get a ip from my ISP. I think that the router cant't receive any DNS... Telia use dynamic DHCP and DNS. I have set the encapsulation mode to "RFC 1483 llc/snap"

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
stephen.stack Wed, 11/28/2007 - 11:59

Hi Johan,

Perhaps you could post some of your config here for us to trouble shoot. One thing thats comes to mind is...

If you are using a dialer interface, then use the command

ip address negotiate


ip address dhcp


Please rate all posts



patrickvanham Thu, 11/29/2007 - 07:43

Try the following configuration, I believe pvc 8/35 is used by Telia. Most european DSL providers work with bridging, so a dialler interface isn't used but rather a bridge interface.

bridge irb

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 8/35

encapsulation aal5snap

dsl operating-mode auto

bridge-group 1

interface BVI1

ip address dhcp

ip nat outside

ip classless

ip route BVI1

bridge 1 protocol ieee

bridge 1 route ip

Johan_Melin Sun, 12/02/2007 - 13:38

Hmm ok, I have tested this configuration but whitout success. How to update firmware? Are there anyone who have a guide?

Paolo Bevilacqua Sun, 12/02/2007 - 14:21

First, you need to have customer-level access to CCO for download IOS software. This requires a purchasing and registering a support contract for the router.

Anyway, first check that you have DSL connectivity with "show dsl interface".

Note in the example above, there should NO command like "ip route BVI1".

Instead, "ip dhcp" can be acceptable, or nothing at all.


This Discussion