Cisco 7911 phone voice VLAN issues

Unanswered Question
Nov 29th, 2007

Hi,


I'm having an issue with some new Cisco 7906 and 7911 phones plugged into a Cisco 3560 switch. They do not seem to pick up the voice VLAN from the switch and hence do not get an IP or register with CallManager, 7960s on the same switch work fine. I have managed to recreate this in a test environment with a 7921 router and a 3560 switch. Configuration is as follows, there is a trunk between the 1721 (Fa0) and 3560 (Fa0/1).


c1721#show run

Building configuration...


!

interface FastEthernet0

description Trunk to c3560

no ip address

speed auto

!

interface FastEthernet0.1

description Voice

encapsulation dot1Q 1 native

ip address 10.11.12.1 255.255.255.0

!

interface FastEthernet0.2

description Data

encapsulation dot1Q 2

ip address 192.168.0.1 255.255.255.0

!


c3560#sh run

Building configuration...


!

interface FastEthernet0/1

description Trunk to c1721

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/17

description 7911

switchport access vlan 2

switchport voice vlan 1

spanning-tree portfast

!

interface FastEthernet0/18

description 7960

switchport access vlan 2

switchport voice vlan 1

spanning-tree portfast

!


Running the latest software on the above lab setup:


c1721 router: c1700-advsecurityk9-mz.124-17a.bin

c3560 switch: c3560-ipbase-mz.122-40.SE.bin

c7911 phone: SCCP11.8-3-3SR2S


Has anyone come accross this this? It seems to be similar to CSCsg07708 'init never performs reimage in certain rare timing instances' which has been mentioned at least once on this forum, but this is happening constantly even once the phone has upgraded, if you power cycle the phone it doesn't register again. If you configure the switch ports as access ports in the voice VLAN the phones register immediately. Changing the voice VLAN to VLAN 3 on the router and switch seems to help but it is still intermittent and older 7911 phone firmware seems to have more of an issue. Any suggestions would be much appreciated.



Thanks,


Jono

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Nelson Thu, 11/29/2007 - 18:48


In addition to the image issues with the 7911's you mentioned, I'd make sure you have a native VLAN on the 3560 as well. This would be one step to alleviate some of the issues.


At the end of the day the 7911's are notorious for their issues. I've experienced them personally on a dozen or so installs.


HTH


Thanks,

Jon

Actions

This Discussion