CE-1 recieves CE-2 routes but can ping them

Unanswered Question
Nov 30th, 2007
User Badges:

I am building a lab to simulate enterprise WAN would connect over MPLS cloud.

The problem is CEs receives the routes of each other, but can't ping any.


I have attached the config. file for the basic routers in the lab setup; CE-1, PE-1, PE-2.


Appreciate your help.


Sami




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mheusing Fri, 11/30/2007 - 01:59
User Badges:
  • Cisco Employee,

Hi,


you have to make sure to have MPLS enabled end to end between the two PE routers. So what is missing:


r7-PE1

interface FastEthernet0/0

ip address 78.78.78.7 255.255.255.0

speed 100

full-duplex

mpls ip

mpls label protocol ldp

mpls mtu 1512


r8-PE2

interface FastEthernet0/0

ip address 78.78.78.8 255.255.255.0

speed 100

full-duplex

mpls ip

mpls label protocol ldp

mpls mtu 1512


Check your environment with "show mpls ldp discovery", "show mpls ldp neighbors", "show mpls forwarding-table". The latter should show you a "Pop" for the loopbacks of the other PE and some labels with a [V] for the VPN routes.


Hope this helps! Please rate all posts.


Regards, Martin

ccie16351 Fri, 11/30/2007 - 07:08
User Badges:

Hi Martin,

unfortunately, my current IOS image doesn't support "mpls ip/tag-switching'. Here it is

c3660-ik9s-mz.123-14.T7.bin.


Are you aware of an inmage can support it with 32F/128DRAM on 3660.


Appreciate your help.


ccie16351 Fri, 11/30/2007 - 09:08
User Badges:

Hi Martin,

I managed to upgrade the IOS of the PEs to support MPLS, but problem still persist; CEs receives the routes of each other but can ping them.

r6-CE1#sir bgp

44.0.0.0/32 is subnetted, 1 subnets

B 44.44.44.44 [20/0] via 67.67.67.7, 00:03:02

r6-CE1#p 44.44.44.44


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 44.44.44.44, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

-------------------------------

r7-PE1#sh run int fa0/0

Building configuration...


Current configuration : 136 bytes

!

interface FastEthernet0/0

ip address 78.78.78.7 255.255.255.0

speed 100

full-duplex

tag-switching mtu 1512

tag-switching ip

end


r7-PE1#sh mpls forwarding-table

Local Outgoing Prefix Bytes tag Outgoing Next Hop

tag tag or VC or Tunnel Id switched interface

16 Pop tag 88.88.88.88/32 0 Fa0/0 78.78.78.8

17 Untagged 10.10.10.0/24[V] 0 Fa0/1 67.67.67.6

18 Untagged 16.16.16.0/24[V] 0 Fa0/1 67.67.67.6

19 Untagged 30.30.30.0/24[V] 0 Fa0/1 67.67.67.6

20 Untagged 66.66.66.66/32[V] 570 Fa0/1 67.67.67.6

r7-PE1#88.88.88.88


r8#sh run int fa0/0

interface FastEthernet0/0

ip address 78.78.78.8 255.255.255.0

speed 100

full-duplex

tag-switching mtu 1512

tag-switching ip


r8#sh mpls forwarding-table

Local Outgoing Prefix Bytes tag Outgoing Next Hop

tag tag or VC or Tunnel Id switched interface

16 Pop tag 77.77.77.77/32 0 Fa0/0 78.78.78.7

23 Untagged 44.44.44.44/32[V] 1140 Fa0/1 48.48.48.4

r8#exi



mheusing Mon, 12/03/2007 - 05:26
User Badges:
  • Cisco Employee,

Hi,


did you try an extended ping between CE Loopbacks? Might be that you use outgoing interface IP as source and do not announce the network. Did you debug ICMP on a CE (lab only) to verify packet (non-)arrival?

Could you also check on both PE routers:

show mpls ldp discovery

show mpls ldp neighbor

and make sure CEF is working properly.


Regards, Martin

ccie16351 Mon, 12/03/2007 - 07:57
User Badges:

Thanks Martin,

I got working after I had the CE routers advertises the interface to their peers, in the bgp.


As usual, apprecite your help.


Sami

Actions

This Discussion