IP Communicator over Windows VPN

Unanswered Question
Nov 30th, 2007
User Badges:

CIPC when on our local network will register fine, but when I take the laptop home and connect via VPN CIPC is stuck at "Registering"


I can establish the VPN and have tested connectivity to my CCME system via ping.


Here is "debug tftp events" when CIPC is trying to register via VPN.


.Nov 30 09:07:46.379: TFTP: Looking for CTLSEP00046193CDD4.tlv

.Nov 30 09:07:51.495: TFTP: Looking for SEP00046193CDD4.cnf.xml

.Nov 30 09:07:52.271: TFTP: Opened system:/its/XMLDefaultCIPC.cnf.xml, fd 1, size 959 for process 96

.Nov 30 09:07:52.391: TFTP: Finished system:/its/XMLDefaultCIPC.cnf.xml, time 00:00:00 for process 96

.Nov 30 09:07:54.227: TFTP: Looking for English_United_States\CIPC_Locale.loads

.Nov 30 09:07:58.103: TFTP: Looking for Communicator\LdapDirectories.xml

.Nov 30 09:07:59.203: TFTP: Looking for Communicator\LdapDialingRules.xml

.Nov 30 09:08:04.899: TFTP: Looking for CTLSEP00046193CDD4.tlv

.Nov 30 09:08:04.999: TFTP: Looking for CTLSEP00046193CDD4.tlv

.Nov 30 09:08:08.735: TFTP: Looking for CTLSEP00046193CDD4.tlv

.Nov 30 09:08:08.987: TFTP: Looking for CTLSEP00046193CDD4.tlv

.Nov 30 09:08:09.167: TFTP: Looking for CTLSEP00046193CDD4.tlv

.Nov 30 09:08:09.263: TFTP: Looking for CTLSEP00046193CDD4.tlv

.Nov 30 09:08:09.323: TFTP: Looking for SEP00046193CDD4.cnf.xml

.Nov 30 09:08:09.323: TFTP: Opened system:/its/XMLDefaultCIPC.cnf.xml, fd 1, size 959 for process 96

.Nov 30 09:08:09.459: TFTP: Finished system:/its/XMLDefaultCIPC.cnf.xml, time 00:00:00 for process 96

.Nov 30 09:08:09.587: TFTP: Looking for CTLSEP00046193CDD4.tlv

.Nov 30 09:08:09.703: TFTP: Looking for English_United_States/ipc-sccp.jar

.Nov 30 09:08:09.767: TFTP: Looking for CTLSEP00046193CDD4.tlv

.Nov 30 09:08:09.823: TFTP: Looking for United_Kingdom/g3-tones.xml

.Nov 30 09:11:04.419: TFTP: Looking for CTLSEP00046193CDD4.tlv

.Nov 30 09:11:04.475: TFTP: Looking for SEP00046193CDD4.cnf.xml

.Nov 30 09:11:04.475: TFTP: Opened system:/its/XMLDefaultCIPC.cnf.xml, fd 1, size 959 for process 96

.Nov 30 09:11:04.611: TFTP: Finished system:/its/XMLDefaultCIPC.cnf.xml, time 00:00:00 for process 96

.Nov 30 09:11:04.623: TFTP: Looking for CTLSEP00046193CDD4.tlv

.Nov 30 09:11:04.679: TFTP: Looking for English_United_States/ipc-sccp.jar

.Nov 30 09:11:04.751: TFTP: Looking for CTLSEP00046193CDD4.tlv

.Nov 30 09:11:04.807: TFTP: Looking for United_Kingdom/g3-tones.xml


It seems to get stuck on g3-tones.xml , and keeps looping over that same section again and again.


Are there any other debugs I can capture to try find out what is causing this issue?


Also "debug ephone register", and "debug ephone detail mac-address xxxx.xxxx.xxxx" dont produce anything.


Many thanks,

David



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
mchandak Fri, 11/30/2007 - 07:24
User Badges:
  • Gold, 750 points or more

One of the most common reasons for this to happen is CIPC tries to register using the name SEP. When connected on VPN, it could be using the VPN Virtual NIC MAC Address and could be causing the issue. Can you configure the name as SEP. To do this, you need to go to Preferences|Network|Use This device Name and mention the same.


Hope this helps

d.bigerstaff Fri, 11/30/2007 - 11:20
User Badges:

Thanks for your help so far,


CIPC was already using the correct mac address in the device name. There's a couple of PCs that i'm having this problem with. My home PC and a laptop which works in our office but not on VPN.


I'll see if I can test the device name on the other computer as well.


Where could i next look to see where this problem is arising?

Actions

This Discussion