Load balancing? which system?

Unanswered Question
Nov 30th, 2007
User Badges:

Hello.

I have two DSL in my office. I want a router into which I can plug the two internet connections. The best way would be a load balancing between the two DSL.

I need a system that if one DSL stops working, the router automaticly uses the other.

The most important thing is that the office always has internet.


Which system should I use? Router, Router-modem, swtich...? And which model?


Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
bjornarsb Fri, 11/30/2007 - 04:27
User Badges:
  • Bronze, 100 points or more

Hi,


Are the two dsl's from the same provider?

If yes they must aggree on the the configuration.

If not, and you have services that has to be reached from Internett, you cannot get full redundancy. The public IP adresses belongs to the ISP and cannot be routed in the AS of your other ISP.

Use NAT overloading and HSRP, then you will always get user access to Internet.


HTH


BR

Bjornarsb

pau123456 Fri, 11/30/2007 - 05:04
User Badges:

Thanks for your reply.


The dsl's are from diferent providers.

I have been reading about HSRP, and I think this will be good.

Which cisco router have this functionality?


Thanks.

bjornarsb Fri, 11/30/2007 - 06:50
User Badges:
  • Bronze, 100 points or more

Hi,


871 or 1800 series.



BR,

Bjornarsb

bjornarsb Wed, 12/05/2007 - 00:33
User Badges:
  • Bronze, 100 points or more

Hi,


You could start looking at this example:

http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a0080093f2c.shtml


and this:

http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a00800945bf.shtml#conf5


Keep in mind that the configuration depends on if you have Provider Independent Addresses or not.


HTH


BR,

Bjornarsb

rechard_david Thu, 12/06/2007 - 18:59
User Badges:

Dear Bjornarsb,


I'm glad to hear your reply and thank you!!

so i would like to ask you one question i had one 1841 and 3 interface Ethernet and i connect like this :

ISP 1 connect to int f0/0 , ISP 2 connect to f0/1 and int f0/3 connect to Switch(LAN).

i would like configure redundancy i mean when ISP one down, ISP 2 automatic up.

So i not clear about configuration Could give me that i told you above.

Hope to see you reply !!!



Best Regards,

Rechard

bjornarsb Fri, 12/07/2007 - 00:50
User Badges:
  • Bronze, 100 points or more

Hi,


Do you have private or public IP on your LAN Interface ?



BR,

Bjornarsb

rechard_david Fri, 12/07/2007 - 01:18
User Badges:

Dear Bjornarsb,


Sure, i had. 2 ISP use public ip and Lan is private IP.

Could you tell me 2 option?

1-If ISP 1 down switch automatically to ISP 2.

2-Use both ISP i mean ISP 1 50% and ISP 2 50%.

Could you give me some document please?


Best Regards,

Rechard

bjornarsb Fri, 12/07/2007 - 01:46
User Badges:
  • Bronze, 100 points or more

Hi,


If I've understood your need, try this:


!

interface FastEthernet0/0

description ## LAN ###

ip address 192.168.253.1 255.255.255.0

ip nat inside

!

interface FastEthernet0/1

description ## ISP 1 ###

ip address 193.1.1.1 255.255.255.252

ip nat outside

!

interface FastEthernet0/2

description ## ISP 2 ###

ip address 193.2.2.1 255.255.255.252

ip nat outside



ip nat inside source list 102 interface FastEthernet0/1 overload

ip nat inside source list 102 interface FastEthernet0/2 overload



access-list 102 permit ip 192.168.253.0 0.0.0.255 any


50% each


ip route 0.0.0.0 0.0.0.0 193.1.1.2

ip route 0.0.0.0 0.0.0.0 193.2.2.2


ISP2 just standby



ip route 0.0.0.0 0.0.0.0 193.1.1.2

ip route 0.0.0.0 0.0.0.0 193.2.2.2 200



BR,


Bjornarsb

rechard_david Fri, 12/07/2007 - 02:53
User Badges:

Dear Bjornarsb,


Thank you very much for your help!!

i will be test it.You mean i if you configure command bellow is use ISP1 50% and ISP2 50%, right?

!

interface FastEthernet0/0

description ## LAN ###

ip address 192.168.253.1 255.255.255.0

ip nat inside


!

interface FastEthernet0/1

description ## ISP 1 ###

ip address 193.1.1.1 255.255.255.252

ip nat outside


!

interface FastEthernet0/2

description ## ISP 2 ###

ip address 193.2.2.1 255.255.255.252

ip nat outside




ip nat inside source list 102 interface FastEthernet0/1 overload

ip nat inside source list 102 interface FastEthernet0/2 overload



access-list 102 permit ip 192.168.253.0 0.0.0.255 any


50% each


ip route 0.0.0.0 0.0.0.0 193.1.1.2

ip route 0.0.0.0 0.0.0.0 193.2.2.2

---------------------------------------

And i use this command mean ISP2 Stanby, right?

!

interface FastEthernet0/0

description ## LAN ###

ip address 192.168.253.1 255.255.255.0

ip nat inside


!

interface FastEthernet0/1

description ## ISP 1 ###

ip address 193.1.1.1 255.255.255.252

ip nat outside


!

interface FastEthernet0/2

description ## ISP 2 ###

ip address 193.2.2.1 255.255.255.252

ip nat outside




ip nat inside source list 102 interface FastEthernet0/1 overload

ip nat inside source list 102 interface FastEthernet0/2 overload



access-list 102 permit ip 192.168.253.0 0.0.0.255 any


ip route 0.0.0.0 0.0.0.0 193.1.1.2

ip route 0.0.0.0 0.0.0.0 193.2.2.2 200


Best Regards,

Rechard

bjornarsb Fri, 12/07/2007 - 02:56
User Badges:
  • Bronze, 100 points or more

yes. and let me know how it goes :)

rechard_david Sun, 12/09/2007 - 23:34
User Badges:

Dear Bjornarsb,


Ok,let me test.

I will let you know. now i met the problem with module Hwic-1FE after i fix already i will update you to you.

Thank you for your support!!!


Besst Regards,

Rechard

Actions

This Discussion