ACE: Preempt is not working

Answered Question
Nov 30th, 2007

Preempt is not working

- It is configured as default on primary and disabled on secondary, it appears correctly in sh ft group x detail

The failover appears to work as far as FT is concerned.

The two start out as

Primary:

My State : FSM_FT_STATE_ACTIVE

My Config Priority : 200

My Net Priority : 200

My Preempt : Enabled

Peer State : FSM_FT_STATE_STANDBY_HOT

and

Secondary

My State : FSM_FT_STATE_STANDBY_HOT

My Config Priority : 95

My Net Priority : 95

My Preempt : Disabled

Peer State : FSM_FT_STATE_ACTIVE

When the primary is reloaded, the secondary appears as follows:

My State : FSM_FT_STATE_ACTIVE

My Config Priority : 95

My Net Priority : 95

My Preempt : Disabled

Peer State : FSM_FT_STATE_UNKNOWN

When the primary comes up again, it's state is as follows:

My State : FSM_FT_STATE_STANDBY_HOT

My Config Priority : 200

My Net Priority : 200

My Preempt : Enabled

Peer State : FSM_FT_STATE_ACTIVE

Note, preempt is enabled but it's still in standby state.

I have to do a manual switchover which works fine.

Any suggestions for this problem?

I have this problem too.
0 votes
Correct Answer by Gilles Dufour about 9 years 3 days ago

I believe that for preempt to work correctly on ACE, it must be configured on both side.

Could you give it a try ?

Tx.

Gilles.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Gilles Dufour Fri, 11/30/2007 - 12:51

I believe that for preempt to work correctly on ACE, it must be configured on both side.

Could you give it a try ?

Tx.

Gilles.

Actions

This Discussion