ip network (Vlan)

Unanswered Question

hello1

i have 4 layer 3 interface;

int vlan 100(ip:1.1.100.1)

int vlan 101(ip:1.1.101.1)

int vlan 102.(ip:1.1.102.1)

i have to enable ipx network on these vlans.

do i need to assigne different network numberes to these vlan or the same for these 3 vlans ?e,g:

ipx routing

for vlan 100:

int vlan 100

ipx network 100 encapsulation SAP

for vlan 101

int vlan 101

ipx network 101 encapsulation SAP

for vlan 102

int vlan 102

ipx network 102 encapsulation SAP

many thannks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
Jon Marshall Fri, 11/30/2007 - 09:20

Ali

You should have no problem with this configuration as you can use the vlan numbers as your IPX network numbers if that is what you want.

Jon

Edison Ortiz Fri, 11/30/2007 - 10:00

When assigning network numbers to interfaces that support multiple networks, you can also configure primary and secondary networks.

The first logical network you configure on an interface is considered the primary network. Any additional networks are considered secondary networks. Again, each network on an interface must use a distinct encapsulation and it should match that of the clients and servers using the same network number.

Edison Ortiz Fri, 11/30/2007 - 10:33

The answer depend upon the IPX stack running on those devices.

WindowsXP auto-detects the LAN IPX Network as well as the IPX Frame-Type if running 802.2. I've seen issues auto-detecting 802.3.

As for the servers, same as the clients, it depends. Are you talking about NetWare servers or other OSes ?

Edison Ortiz Fri, 11/30/2007 - 11:09

You need to bind the LAN IPX Number and Frame-Type manually.

It's been a while since I dealt with NetWare but if I recall, the command is LOAD INETCFG and follow the prompts.

Jon Marshall Fri, 11/30/2007 - 09:37

Ali

No you can't use the same IPX network number on the 3 vlans because they are separate vlans. You need to stick with your original addressing scheme and make sure you enable "ipx routing".

Not sure about the "secondary" statement in your other question, perhaps someone else could explain.

Jon

Actions

This Discussion