Connecting 2514 and 3750

Unanswered Question
Dec 4th, 2007
User Badges:

Hi all,


I am new to CISCO devices.

I am trying to connect 2514 and 3750.

I tried as below in 3750 :

Cisco(config)#interface fastEthernet 1/0/2

Cisco(config-if)#ip ad

Cisco(config-if)#ip address 10.0.0.3 25.255.255.0


% IP addresses may not be configured on L2 links.

So, I created Vlan in 3750 and added fa1/0/2 to that vlan.


Then, I tried below in 2514 :

Cisco2514-II>(config)#interface Vlan 100

^

% Invalid input detected at '^' marker.


Cisco2514-II>(config)#


I don't know how to make a connection between them.

Kindly someone help me.


Thanks,

Vijaybabu

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
Jon Marshall Tue, 12/04/2007 - 01:50
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi


You cannot create an interface vlan on the 2514. Which interface on the 2514 connects to the 3750. Assuming e0


int e0

ip address 10.10.0.5 255.255.255.0 (choose a 10.10.0.x address you haven't already allocated )

no shut


Make sure the port on the switch that the router connects to is in the same vlan eg


int fa0/1

switchport access vlan 100


HTH


Jon

GillieLucent Tue, 12/04/2007 - 02:05
User Badges:

Hi,


Thanks for you reply.

How to create vlan 100 in 2514 ?


Thanks,

Vijaybabu

Jon Marshall Tue, 12/04/2007 - 02:07
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Hi


You don't need to create vlan 100 on the 2514. You just need to assign the interface connecting to the 3750 switch an IP address out of the vlan 100 subnet range.


Then make sure the port that the router connects into is an access port (ie not a trunk) and make sure that port is put into vlan 100 on the 3750 - see previous post for details.


Jon

GillieLucent Tue, 12/04/2007 - 02:16
User Badges:

Hi,

Below are my configs :

Router 2514 :

interface Ethernet0

ip address 10.0.0.2 255.255.255.0


Router 3750 :


interface FastEthernet1/0/2

switchport access vlan 100

switchport mode access


interface Vlan100

ip address 10.0.0.3 255.255.255.0



But, still I am not able to ping the other side, also themselves.


Thanks,

Vijaybabu


Jon Marshall Tue, 12/04/2007 - 02:33
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Okay, check the basics,


1) Are both interfaces showing as up/up


"sh ip int brief" will show you status of interfaces.


2) Hardcode the speed and duplex to 10 full on both ends.


3) Make sure you are using a straight-thru cable.



HTH


Jon


GillieLucent Tue, 12/04/2007 - 04:16
User Badges:

Hi Jon,


I missed the basic 'straight-thru cable'.

Thanks for your help.


Thanks,

Vijaybabu

Actions

This Discussion