MGCP VG passing incorrect DDI Digits

Answered Question
Dec 5th, 2007

I have an MGCP gateway. Recently we got new DDI lines. 02075491950-2150.


We use a 4 digit extension. so extension 1950 was created for a user.


When the number 02075491950 is dialed, the debug on the gateway shows its delivering 491950 instead of 1950 to callmanager, hence the call does not go through.


How can I strip this 49 number off. Or do I have to tell the carrier company to deliver only 4 digits?


Secondly, I observed that when I created the extension 491950 it stii dint work until i created an inbound dial-peer for it. Since I am running MGCP, I am thinking this is not right.

Correct Answer by Zin.Karzazi about 9 years 2 months ago

Normally when using MGCP you dont need to configure destination-pattern on the voice Gateway, as the Callmanager is controlling the Gateway. Configuring a Translation pattern as i described earlier will work fine and you dont need any otherconfig on your Gateways.


See this note:

All dial plan configuration elements are controlled by Cisco CallManager and should not be configured on the MGCP voice gateway for MGCP-managed endpoints (that is, any endpoint with an application mgcpapp command in its associated dial-peer statement). Also, you should not use the destination-pattern and session target dial-peer configuration commands or use the connection voice-port configuration command on the MGCP voice gateway, unless you are configuring MGCP gateway fallback. To configure MGCP gateway fallback, the H.323 dial peers must be configured with the destination-pattern and session target dial-peer configuration commands.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Zin.Karzazi Wed, 12/05/2007 - 07:35

On your CCM go to Device->Gateways-> choose your gateways-> go to "Call Routing Information" ->Inbound Calls-> Significant Digits* set the Significant Digits to 4.


OR


you can set up a Translation Pattern 491950XXXX with "Called Party Transform Mask" set to XXXX. Ensure that the CSS of your Gateway include the Partition where your Translation Pattern resides.


OR


you can ask your Provider to forward 4 digits for you.

Ayodeji Okanlawon Wed, 12/05/2007 - 08:10

Zin,


Thanks but one more problem


Why Do I need to configure destination-pattern for the inboud extension 491950 before it worked. I believe with MGCP this should not happen

Rajesh Revuru Wed, 12/05/2007 - 08:02

If your service provider is sending 7 digits, and you have configured 4 digits for your users, select 7 digits under the "Significant digits" under gateway configuration page, and use a translation pattern to strip pre-3 digits



HTH

Correct Answer
Zin.Karzazi Wed, 12/05/2007 - 08:21

Normally when using MGCP you dont need to configure destination-pattern on the voice Gateway, as the Callmanager is controlling the Gateway. Configuring a Translation pattern as i described earlier will work fine and you dont need any otherconfig on your Gateways.


See this note:

All dial plan configuration elements are controlled by Cisco CallManager and should not be configured on the MGCP voice gateway for MGCP-managed endpoints (that is, any endpoint with an application mgcpapp command in its associated dial-peer statement). Also, you should not use the destination-pattern and session target dial-peer configuration commands or use the connection voice-port configuration command on the MGCP voice gateway, unless you are configuring MGCP gateway fallback. To configure MGCP gateway fallback, the H.323 dial peers must be configured with the destination-pattern and session target dial-peer configuration commands.

Ayodeji Okanlawon Wed, 12/05/2007 - 11:02

Hi,


I have created the translation pattern...491950..to be xlated to 1950.


When I call 491950 it rings out on 1952..However when I dial the full DDI...02075491950...It says you have dialled an incorrect number...


The CCM trace shows no pattern match...


Cisco CallManagerDigit analysis: match(pi="1",fqcn="", cn="", plv="5", pss="", TodFilteredPss="", dd="491950",dac="0")

-

12/05/2007 18:38:59.570

StandAloneCluster

192.168.2.11

Trace

2,100,61,1.1484

192.168.24.2

Cisco CallManagerDigit analysis: potentialMatches=NoPotentialMatchesExist


The debug isdn q931 shows..



ISDN Se1/0:15 Q931: RX <- SETUP pd = 8 callref = 0x0001

Sending Complete

Bearer Capability i = 0x9090A3

Standard = CCITT

Transfer Capability = 3.1kHz Audio

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98381

Exclusive, Channel 1

Called Party Number i = 0x81, '491950'

Plan:ISDN, Type:Unknown

ISDN Se1/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x8001

Cause i = 0x8081 - Unallocated/unassigned number


what else should I do.




Rajesh Revuru Wed, 12/05/2007 - 08:21

I was exactly referrring to Zin solution.


Please perform one of the three above options, that should take care of it

Zin.Karzazi Wed, 12/05/2007 - 11:14

Did you include the Partition where the translation pattern 491950 resides on the CSS of your Gateway?? DO the CSS of your translation pattern include the Partition where the DN of your phone resides? is the significant digits set to all or to 4 digits??

Ayodeji Okanlawon Wed, 12/05/2007 - 11:25

Yes I did Include the partition in the CSS of my gateway. The significant digit is set to all

Actions

This Discussion