Why EIGRP is not redistributed into BGP within VRF

Unanswered Question

Why my EIGRP routes are not redistributed in BGP within the VRF?


The EIGRP routes (172.16.1.0/24 and 172.16.2.0/24) are in the table as following:

r6#sh ip route vrf CRG001

Routing Table: CRG001

...

172.16.0.0/24 is subnetted, 2 subnets

D 172.16.1.0 [90/409600] via 10.116.20.3, 18:30:04, Ethernet1/0

D 172.16.2.0 [90/409600] via 10.116.20.3, 18:30:01, Ethernet1/0

10.0.0.0/24 is subnetted, 5 subnets

B 10.116.30.0 [20/0] via 10.116.21.2 (CRG005), 1d01h

B 10.116.31.0 [20/0] via 10.116.21.2 (CRG005), 1d01h

C 10.116.20.0 is directly connected, Ethernet1/0

B 10.116.10.0 [20/0] via 10.116.20.2, 18:41:29

B 10.116.11.0 [20/0] via 10.116.20.2, 18:41:29

r6#


But are not in the BGP table:

r6#sh ip bgp vpnv4 vrf CRG001

BGP table version is 9076, local router ID is 172.16.56.6

...

Network Next Hop Metric LocPrf Weight Path

Route Distinguisher: 2:1 (default for vrf CRG001)

*> 10.116.10.0/24 10.116.20.2 0 0 65208 10 i

*> 10.116.11.0/24 10.116.20.2 0 0 65208 10 i

*> 10.116.30.0/24 10.116.21.2 0 0 64600 i

*> 10.116.31.0/24 10.116.21.2 0 0 64600 i

r6#


Here is my config:

!

router eigrp 113

no auto-summary

!

address-family ipv4 vrf CRG001

network 10.116.20.0 0.0.0.255

no auto-summary

autonomous-system 1

exit-address-family

!

router bgp 65231

no synchronization

bgp log-neighbor-changes

timers bgp 3 9

no auto-summary

!

address-family ipv4 vrf CRG001

redistribute eigrp 1

neighbor 10.116.20.2 remote-as 65208

neighbor 10.116.20.2 activate

neighbor 10.116.20.2 next-hop-self

no auto-summary

no synchronization

network 10.116.20.0 mask 255.255.255.0

exit-address-family

!


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mheusing Wed, 12/05/2007 - 09:20

Hi,


That is an interesting question, because the config excerpt you give looks correct. In addition 10.116.20/24 is also missing in the VRF BGP table.

Did you try to remove and readd the redistribution statement?

Could you provide the VRF and interface configs as well?


Regards, Martin

Hi Martin,


The reason for 10.116.20.0/24 is not in BGP table was because I have import route-map to block that.


Here is my config for VRF and interfaces:

!

ip cef

!

ip vrf CRG001

rd 2:1

import map CRG001_import

route-target export 2:1

route-target import 2:1

route-target import 2:5

!

interface Ethernet1/0

ip vrf forwarding CRG001

ip address 10.116.20.1 255.255.255.0

!

ip as-path access-list 1 permit ^64600$

!

route-map CRG001_import permit 10

match as-path 1

!

router eigrp 113

no auto-summary

!

address-family ipv4 vrf CRG001

network 10.116.20.0 0.0.0.255

no auto-summary

autonomous-system 1

exit-address-family

!

router bgp 65231

no synchronization

bgp log-neighbor-changes

timers bgp 3 9

no auto-summary

!

address-family ipv4 vrf CRG001

redistribute eigrp 1

neighbor 10.116.20.2 remote-as 65208

neighbor 10.116.20.2 activate

neighbor 10.116.20.2 next-hop-self

no auto-summary

no synchronization

network 10.116.20.0 mask 255.255.255.0

exit-address-family

!


Martin,


Looks like I found my own problem, the import route-map also need to include ^$ and it is OK now...


!

ip as-path access-list 1 permit ^64600$

ip as-path access-list 1 permit ^$

!


r6#sh ip bgp vpn vrf CRG001

BGP table version is 9649, local router ID is 172.16.56.6

...

Network Next Hop Metric LocPrf Weight Path

Route Distinguisher: 2:1 (default for vrf CRG001)

*> 10.116.10.0/24 10.116.20.2 0 0 65208 10 i

*> 10.116.11.0/24 10.116.20.2 0 0 65208 10 i

*> 10.116.20.0/24 0.0.0.0 0 32768 i

*> 10.116.21.0/24 0.0.0.0 0 32768 i

*> 10.116.30.0/24 10.116.21.2 0 0 64600 i

*> 10.116.31.0/24 10.116.21.2 0 0 64600 i

*> 172.16.1.0/24 10.116.20.3 409600 32768 ?

*> 172.16.2.0/24 10.116.20.3 409600 32768 ?

r6#


Thanks,

Actions

This Discussion