Aniserver problem

Answered Question
Dec 5th, 2007
User Badges:

I have a problem with my ciscoworks. From campus manager i can't connect to aniserver. It is really a nightmare and it keeps recurring.


Winnie.

Correct Answer by David Stanford about 9 years 4 months ago

SyslogAnalyzer should be up and running as well. Looks like you have some issues with this server too.


Can you check the stdout.log found in NMSROOT\MDC\tomcat\logs to see if there are any errors in there?


What are your services set to in the control panel for CiscoWorks?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (6 ratings)
Loading.
David Stanford Wed, 12/05/2007 - 10:46
User Badges:
  • Cisco Employee,

What version of Campus Manager? What OS and browser versions?


Are you connecting to LMS via hostname or IP address?


If you run pdshow what is the status of ANIServer?

wwanjohi123 Wed, 12/05/2007 - 21:25
User Badges:

-Campus Manager Ver is 4.0.3

-OS: Windows server 2003 standard edition

-Browser Ver is I.E 6.0

-Am connecting to LMS via IP Address

-PDshow Status "Administrator has shut down this server" See attached.

-I have a database of about 280 devices, kindly advice what what hardware resources i require on my server in terms of memory nd processor capacity.



Attachment: 
gaborjuhasz Wed, 12/12/2007 - 02:12
User Badges:

Do you have a multi-home server? I mean, do you have more than one NIC in your server?

If so, please configure the following file:

...\CSCOpx\lib\vbroker\gatekeeper.cfg


Look for the following and set the correct IP address:


#******************* BEGIN MULTI-HOME PROPERTIES ****************************

# A multi-home machine would have multiple NIC cards each configured

# with different IP address. Please select one IP address as your

# external address using which the client would login to the CW2000

# server. Replace the "" string which appears below

# with external IP address. Uncomment the property by removing the '#'

# character.

#vbroker.gatekeeper.backcompat.callback.host=

#vbroker.se.exterior.host=

#vbroker.se.iiop_tp.host=

#vbroker.se.interior.host=

#******************* END MULTI-HOME PROPERTIES ******************************


David Stanford Wed, 12/12/2007 - 06:29
User Badges:
  • Cisco Employee,

From looking at the pdshow output you have many more processes that are shut down which should be running.


Have you changed any of the services in the control panel from Automatic to Manual?


Also, has the casuser account or password been changed on the server?

wwanjohi123 Thu, 12/13/2007 - 04:24
User Badges:

Davistan,

I got another new server and loaded all the modules a fresh, before i could even perform a device discovery the ANIserver process shows that the administrator has shut it down. What could this problem be?

David Stanford Thu, 12/13/2007 - 06:19
User Badges:
  • Cisco Employee,

Also check and see which other processes are shut down on this server. There may be processes ANIServer depends on that are also down.


Have you modified the casuser account on the system at all or the services in the control panel?

wwanjohi123 Thu, 12/13/2007 - 06:52
User Badges:

The only processes that are down are: DFMCTMStartup, DataPurge and SyslogAnalyzer.

I haven't modified the causer account and the services are all running in the control panel.

Correct Answer
David Stanford Thu, 12/13/2007 - 07:11
User Badges:
  • Cisco Employee,

SyslogAnalyzer should be up and running as well. Looks like you have some issues with this server too.


Can you check the stdout.log found in NMSROOT\MDC\tomcat\logs to see if there are any errors in there?


What are your services set to in the control panel for CiscoWorks?

wwanjohi123 Thu, 12/13/2007 - 07:35
User Badges:

Apparently i restarted the Deamon and SyslogAnalyzer started running however some are still not running, i have attached the log file and the processes screen shorts. I will wait for your reply.



Attachment: 
wwanjohi123 Thu, 12/13/2007 - 08:04
User Badges:

What phone number can i call you on or are you on on Skype chat??

frankzehrer Thu, 12/13/2007 - 23:09
User Badges:
  • Silver, 250 points or more

Hi Winnie,


is the windows server a standalone or does he belong to a domain?

If he belongs to a domain:

- maybe there are policies denying the casuser and the casusers group the access to the CSCOpx Directory.

- The casuser and the casusers group needs to be local on the server.

- Did you or some policies changed the settings of the windows services?

Every service beginning with "CiscoWorks .." has to be manual startup mode. Except the Deamon Manager he should be in Automatic mode.


Maybe you want to run the script:

\CSCOpx\setup\support\resetcasuser.exe to reset the password for the user.


Do you have a Anti-vir programm running. Some of them restrict the useage of unknown services.


Have a look on this.

Good luck and best regards,


Frank

wwanjohi123 Sun, 12/16/2007 - 02:14
User Badges:

Thanks you so much Frank,

The server is a standalone server and the Causer is local. Am running McAfee antivirus.

About the services i changed them to automatic, now since this was a new installation i have just unistalled all the modules and i'll install it again in a another folder. Tell me where can i get the best practice material for the installation and configuration of ciscoworks? or where can one get training? I have read the user guides but i didn't see some advice like the services starting with Ciscoworks should be on manual mode except the deamon, may be that where i go wrong all the time.

Winnie.

miheg Sun, 12/16/2007 - 12:53
User Badges:
  • Gold, 750 points or more

Better put all services back to manual except de the Daemon manager.


The stuff produces enough errors in the log when it is started in the right order by the daemon manager. If all services just start when they please generating errors might be the only thing they will ever do.


You may also want to put mcafee to manual and start it when the server works as it should. You don't really need it unless many users have access to the ciscoworks file system which is to be avoided anyway.


I hope you followed the guidelines of the install guide? Do install via RDP. ultraVNC always worked fine for me.

Cheers,


Michel

frankzehrer Sun, 12/16/2007 - 20:43
User Badges:
  • Silver, 250 points or more

Hi Winnie,


since you are using LMS 2.5.1, just use this link for installation guideance:

http://www.cisco.com/en/US/products/sw/cscowork/ps2425/products_quick_start09186a00805af28a.html


You'll find here all of the install guides for all versions:

http://www.cisco.com/en/US/products/sw/cscowork/ps2425/prod_installation_guides_list.html


Best reagrds,

Frank

wwanjohi123 Sun, 12/16/2007 - 21:13
User Badges:

Thank you all,

I re-installed ciscoworks locally and not through RDP and my servics are manual except the deamon. I will work without the MacAfee untill it works well. i'll also check out the links for more info.

Once again, Thank you all.

Best Regards

Winnie.

wwanjohi123 Tue, 12/18/2007 - 08:38
User Badges:

Hi,

I need to discover devices only with loopback addresses to avoid duplication of devices by virtual addresses. How do ii do this?

Winnie.

David Stanford Tue, 12/18/2007 - 12:40
User Badges:
  • Cisco Employee,

For any account configured in CiscoWorks go to Server - Security - Local User setup. This is where passwords are configured.


If you are talking about casuser then you need to use resetCasuser.exe to change the password.

wwanjohi123 Wed, 12/19/2007 - 02:03
User Badges:

Will it affect the running of the application in any way? Will it request me to input another password that i will know, this is because i need to configure RCP on all my Cisco devices for RME to work and i'll require to input the same cwuser password on the devices.

See below:


"username cwuser password 7 000C1C0A05

ip rcmd rcp-enable

ip rcmd remote-host cwuser 172.16.15.15 cwuser enable

ip rcmd remote-username cwuser"


David Stanford Wed, 12/19/2007 - 06:00
User Badges:
  • Cisco Employee,

Ok this is different...this is a username used to access the devices.


If you have already added the attributes to the DCR then you can determine this password by exporting a device attributes to csv file. This will show the password in clear text (if you export a device that has this configured)


Also, I suggest starting new threads on the forum for each issue that you have so that all can read and make suggestions.

Actions

This Discussion