MGCP VG and issues with DDI

Answered Question
Dec 5th, 2007

I have an MGCP gateway. Recently we got new DDI lines. 02075491950-2150.

We use a 4 digit extension. so extension 1950 was created for a user.

When the number 02075491950 is dialed, the debug on the gateway shows its delivering 491950 instead of 1950 to callmanager, hence the call does not go through.

I have created the translation be xlated to 1950.

When I call 491950 it rings out on 1952..However when I dial the full DDI...02075491950...It says you have dialled an incorrect number...

The CCM trace shows no pattern match...

<info>Cisco CallManagerDigit analysis: match(pi="1",fqcn="", cn="", plv="5", pss="", TodFilteredPss="", dd="491950",dac="0")</info>


- <trace>

<Date>12/05/2007 18:38:59.570</Date>





<SrcDev />


<CTMapKey />

<CTMapVal />

<info>Cisco CallManagerDigit analysis: potentialMatches=NoPotentialMatchesExist</info>


The debug isdn q931 shows..

ISDN Se1/0:15 Q931: RX <- SETUP pd = 8 callref = 0x0001

Sending Complete

Bearer Capability i = 0x9090A3

Standard = CCITT

Transfer Capability = 3.1kHz Audio

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98381

Exclusive, Channel 1

Called Party Number i = 0x81, '491950'

Plan:ISDN, Type:Unknown

ISDN Se1/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x8001

Cause i = 0x8081 - Unallocated/unassigned number

what else should I do.

I have this problem too.
0 votes
Correct Answer by allan.thomas about 8 years 10 months ago

Incidentally, I assume that you are able to ring the DN from another IP Phone?

I can I suggest that you use the DNA and ascertain whether you are able to route the call from gateway to the DN?



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Rajesh Revuru Wed, 12/05/2007 - 11:08


Can you make sure the number '1950' is in correct partition/CSS, because from the debug it says as

Cause i = 0x8081 - Unallocated/unassigned number.

For some reason call manager cannot find that number

csdng1 Wed, 12/05/2007 - 11:13

Do you know how many digits you are being sent by the provider (e.g. BT) I think the standard is 6, but some of our ISDN's are setup for 4.

allan.thomas Wed, 12/05/2007 - 11:20

The simplest of approaches would be to configure the MGCP endpoint to 4 significant digits within the incoming calls under call routing.

Therefore despite the telco forwarding 6 digits, CallManager will only be interested in the last 4. Given that your DID numbers will exactly match the DNs you allocated to phone there is no necessity for further transformations, unless of course you have other number built on the trunk.

The only other consideration is that the MGCP endpoint incoming calls css has the partition which you have assigned to your DNs. For example if you have assign Internal PT to 1950, then the gateway css should include this PT.

Hope this helps.



Ayodeji oladipo... Wed, 12/05/2007 - 11:28

Allan, I did configure the MGCP end Point to use 4 digits yet this did not work.

The CSS gateway includes this partition

Rajesh Revuru Wed, 12/05/2007 - 11:31


Is this happening only with one single number 1950 or any other number having the same issue?

allan.thomas Wed, 12/05/2007 - 11:41

Have you reset the gateway since making any configuration changes?



Ayodeji oladipo... Wed, 12/05/2007 - 11:47

After setting the significant digit to 4, I get 4 digits delivered to callmanager from the CCM tarce. However strangely CCM still says no pattern match. I have the number configured on an active phone

Ayodeji oladipo... Wed, 12/05/2007 - 12:04

I just did that. The funny thing is that when I call the number from an internal phone it rings. However when I dial the DDI it doesnt work

allan.thomas Wed, 12/05/2007 - 12:03

What is the current configuration of the MGCP gateway? Do have 4 or 6 significant digits configured. If you have still 4 digits, then make sure that you do not have any translation patterns which could possible match the incoming number.

You can verify this through the route plan, check for numbers beginning with 19. Another alternative would be to configure another DN from your DID range for example 2150, and see whether you still get unallocated number.



Ayodeji oladipo... Wed, 12/05/2007 - 12:28

I have just used one of the new DDI. It dials out fine but it keeps saying you have dialed an incorrect number when i try to dial in to it.

Correct Answer
allan.thomas Wed, 12/05/2007 - 12:43

Incidentally, I assume that you are able to ring the DN from another IP Phone?

I can I suggest that you use the DNA and ascertain whether you are able to route the call from gateway to the DN?



Ayodeji oladipo... Wed, 12/05/2007 - 13:27


Wonderful! Atlast it worked!.

I used the DNA to see if I could route call from the gateway and I discovered that the pattern was blocked. I also discovered that there was no CSS assigned to the inbound direction. So I assigned the CSS of the gateway to it and restarted MGCP.

And Bingo! Its working! Thanks man for staying with me this long! I do appreciate it.

I actually sent you a response to the viewing files in CCM 5.1, I do not know if you got it.

Basically I wanted to be a personal friend, so I can learn from you!

Many thanks

allan.thomas Wed, 12/05/2007 - 13:43

Hi Deji, no problem, I'm pleased that it is working for you now, appreciate the rating, and best of luck.

Incidentally I never received any response regarding viewing the files?



Ayodeji oladipo... Wed, 12/05/2007 - 14:04

Allan, here is the post I sent on it..

Posted by: aokanlawon - Dec 3, 2007, 5:15am PST

Alan thanks I have been able to see this file as suggested.

I will formally ask to be a friend, you have been very helpful on this forum.

My name is Deji Okanlawon. I work with a cisco Gold Partner by name NSCGlobal in London.

My email is [email protected] and [email protected].

If you could drop me an email, I would love to keep in touch with you and learn from you!

One more thing,

Have you ever chekced the replication status on the Publisher using the utils dbreplication staus command? Each time I try to use it it takes forever and I have had to restart the server because I do not get a response in time.


This Discussion