redistribute bgp into eigrp question

Unanswered Question
Dec 5th, 2007
User Badges:
  • Bronze, 100 points or more

I am doing a simple lab exercise trying to redistribute bgp into eigrp. It is not working. The info I can find on internet such as troubleshooting flow charts says there are mainly 3 reasons: either no metrics, discontiguous nets, or the route is not in the table. Those are not the case but still I can not see the route in the eigrp topology table hence it can't pass that route over to the neighboring eigrp router. What are all the possible reasons why a route from bgp won't distribute into eigrp?


R1


R1#show run

Building configuration...


Current configuration : 1831 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1


ip subnet-zero

ip cef

interface Loopback1

ip address 1.1.1.1 255.255.255.255

!

interface FastEthernet0/0

ip address 10.32.1.3 255.255.0.0

duplex auto

speed auto

!

interface Serial1/0

ip address 68.136.221.66 255.255.255.252

encapsulation frame-relay

serial restart-delay 0

no dce-terminal-timing-enable

frame-relay interface-dlci 221

!

router eigrp 32

redistribute bgp 1 metric 6144 100 255 1 1500

network 1.1.1.1 0.0.0.0

network 10.0.0.0

no auto-summary

!

router bgp 1

no synchronization

bgp log-neighbor-changes

network 10.32.0.0 mask 255.255.0.0

network 63.76.64.88 mask 255.255.255.248

neighbor 68.136.221.65 remote-as 1

neighbor 68.136.221.65 timers 12 36

no auto-summary

!

ip classless



Show Route:

Gateway of last resort is not set


68.0.0.0/30 is subnetted, 1 subnets

C 68.136.221.64 is directly connected, Serial1/0

1.0.0.0/32 is subnetted, 1 subnets

C 1.1.1.1 is directly connected, Loopback1

10.0.0.0/16 is subnetted, 2 subnets

B 10.1.0.0 [200/0] via 68.136.221.65, 00:02:47

C 10.32.0.0 is directly connected, FastEthernet0/0


R1#show ip eigrp top all

IP-EIGRP Topology Table for AS(32)/ID(1.1.1.1)


Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - reply Status, s - sia Status


P 1.1.1.1/32, 1 successors, FD is 128256, serno 2

via Connected, Loopback1

P 10.32.0.0/16, 1 successors, FD is 281600, serno 3

via Connected, FastEthernet0/0


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
cfolkerts Wed, 12/05/2007 - 13:41
User Badges:

Which route or network are you trying to pass into EIGRP?

suelange Wed, 12/05/2007 - 13:47
User Badges:
  • Bronze, 100 points or more

The route that should be going in there is the one learned via BGP which in this case is 10.1.0.0 255.255.0.0.


The 1.1.1.1 route, which is a loop back, is being passed over the the neighboring router via eigrp, so I know that the two routers are doing EIGRP correctly with each other. But the bgp route (10.1.0.0) is not ever being redirected into eigrp topology much less being passed across to the eigrp neighbor.

Richard Burts Wed, 12/05/2007 - 13:55
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Sue


If I am reading the config correctly your BGP neighbor is in the same AS and so is an IBGP neighbor. By default routes learned by IBGP do not redistribute into an Interior routing protocol like EIGRP. So this is the cause of your problem.


You can use the command bgp redistribute-internal under the bgp process to change this behavior. It should allow the redistribution of the BGP routes into EIGRP.


HTH


Rick

suelange Thu, 12/06/2007 - 06:48
User Badges:
  • Bronze, 100 points or more

Yep Yep Yep...that were it....


Thanks so much. I saw that command but know so little still about BGP that I couldn't imagine what bearing it had. The book I was reading indicated BGP is pretty much an external routing protocol. So...what makes it an "internal" version is if it has the same AS number as it's neighbor... Okay good to know that one for the test.

Actions

This Discussion