VLAN not coming up in VTP Domain.

Unanswered Question
Dec 5th, 2007
User Badges:

I have a brand new 3550 set up in its own VTP domain with administrative VLAN 16. My switch is connected to my other VTP Domain via fiber where I have a common VLAN in both VTP Domains to allow communication. I have full communications between VTP Domains. The issue I noticed is that my administrative Vlan will not turn up till I connect another switch that also uses VLAN 16 for only administrative tasks (2950). The 2950 has no ports in VLAN 16. SO I find myself rather confused on why Vlan 16 will not turn up on the 3550 till I connect another switch. I realize that if i connect a computer to the 3550 in VLAN 16 it comes up and if I connect another switch it comes up, but why with just the 3550 will my VLAN 16 not come up?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
srue Wed, 12/05/2007 - 17:28
User Badges:
  • Blue, 1500 points or more

change the 'native vlan' on your trunk ports to 16 - on the switches whose administrative vlan is not 16.


btw, is there a reason you're making the administrative vlan 16 and not leaving it at 1?

glynncounty Wed, 12/05/2007 - 17:36
User Badges:

I guess when the network was built a contractor setup everything and made vlan 16 the management vlan. Thought I am just learning for my CCNA I have noticed several unusual things with the network. I will try making vlan 16 the native vlan.

Francois Tallet Wed, 12/05/2007 - 17:43
User Badges:
  • Gold, 750 points or more

What do you mean by "administrative vlan not up"? How do you determine that? If you are using some STP commands or the status of a vlan interface, be aware that they both depend on whether there is at least active port in this vlan (and even a forwarding port for the vlan interface) on the box. It does not look like a VTP problem at first sight.

Regards,

Francois

glen.grant Wed, 12/05/2007 - 18:01
User Badges:
  • Purple, 4500 points or more

You have to have at least one port active or a trunk link active that has vlan 16 allowed in order for the layer 3 SVI to come active which is why when you connect the 2950 vlan 16 is part of the trunk that feeds it so the SVI will come active . this is part of the autostate function. The behavior will be the same across any IOS switch not just a 3550.


Understanding Autostate


Autostate is implemented on CatOS and IOS Cisco based switches by default. On some CatOS platforms, this feature can be disabled in order to allow redundancy in special scenarios. On IOS based switches, this feature cannot be disabled.


The router VLAN interfaces have to fulfill the following general conditions to be up/up:


*


VLAN exists and is in active status on the switch VLAN database.

*


VLAN interface exists on the router and is not administratively down.

*


At least one L2 (access port or trunk) port exists and has a link up on this VLAN. The latest implementation of the autostate feature allows synchronization to Spanning-Tree Protocol (STP) port status.


A VLAN interface will be brought up after the L2 port has had time to converge (that is, transition from listening-learning to forwarding). This will prevent routing protocols and other features from using the VLAN interface as if it were fully operational. This also prevents other problems, such as routing black holes, from occurring.

*


At least one L2 (access port or trunk) port is in spanning-tree forwarding state on the VLAN.


glynncounty Wed, 12/05/2007 - 18:43
User Badges:

I appreciate all the responses I got. Between all the posts my questions were answered.


Thanks,

bvsnarayana03 Wed, 12/05/2007 - 20:43
User Badges:
  • Silver, 250 points or more

Hi David,

Your query has been already answered. I revise it for you. Except for native vlan, any vlan that you create has to have atleat 1 port in that vlan & device connected to it. otherwise the vlan wont show up. Thats the reason when you connect a host to vlan 16 or another switch, the vlan comes up.


To make this vlan always up you may want it to change to native vlan. you may add the following command under the trunk link to make vlan 16 native:


switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 16


Hope that answers all.



pls rate all helpful posts.

Actions

This Discussion