[cisco-voip] H323 and Callmager Issues

Unanswered Question
Dec 6th, 2007

Hi,

We have a scenario where we have a gateway (cisco 2821 with fxo ports) which we have configured in Cisco Call Manager Ver 4.3(1) as a H.323 gateway. We have Cisco CRS application running the icd.aef script. We are able to hear the IVR prompts if we call using a Cisco IP Phone which is on the same LAN however if we call on the gateway we just hear ringing tones. We changed the setting on the gateway just to check if the call was arriving on call manager or not and we routed the call to a Cisco Hardphone extension and we can answer the call and the call is completed. Attached is the configuration for the gateway. If you need any further information please free to contact me.

Below is the debug out for ccapi from the gateway.

*Dec 6 06:03:34.131: //194/CFCD58F0807D/CCAPI/ccIFCallSetupRequestPrivate:

Interface=0x45BF1094, Interface Type=1, Destination=, Mode=0x0,

Call Params(Calling Number=0212411253(TON=Unknown, NPI=Unknown, Screening=Not

Screened, Presentation=Allowed),

Called Number=8000(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,

Subsriber Type Str=RegularLine, FinalDestinationFlag=TRUE, Outgoing Dial-peer

=1, Call Count On=FALSE,

Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Appl

ication Call Id=)

*Dec 6 06:03:34.131: //195/CFCD58F0807D/CCAPI/ccIFCallSetupRequestPrivate:

SPI Call Setup Request Is Success; Interface Type=1, FlowMode=1

*Dec 6 06:03:34.131: //195/CFCD58F0807D/CCAPI/ccCallSetContext:

Context=0x467323E8

*Dec 6 06:03:34.131: //194/CFCD58F0807D/CCAPI/ccSaveDialpeerTag:

Outgoing Dial-peer=1

*Dec 6 06:03:34.139: //195/CFCD58F0807D/CCAPI/cc_api_call_disconnected:

Cause Value=1, Interface=0x4674BFEC, Call Id=195

*Dec 6 06:03:34.139: //195/CFCD58F0807D/CCAPI/cc_api_call_disconnected:

Call Entry(Responsed=TRUE, Cause Value=1, Retry Count=0)

*Dec 6 06:03:34.139: //195/CFCD58F0807D/CCAPI/cc_api_get_transfer_info:

Transfer Number Is Null

*Dec 6 06:03:34.143: //195/CFCD58F0807D/CCAPI/ccCallSetAAA_Accounting:

Accounting=0, Call Id=195

*Dec 6 06:03:34.143: //195/CFCD58F0807D/CCAPI/ccCallDisconnect:

Cause Value=1, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Ca

use=1)

*Dec 6 06:03:34.143: //195/CFCD58F0807D/CCAPI/ccCallDisconnect:

Cause Value=1, Call Entry(Responsed=TRUE, Cause Value=1)

*Dec 6 06:03:34.143: //195/CFCD58F0807D/CCAPI/cc_api_get_transfer_info:

Transfer Number Is Null

*Dec 6 06:03:34.143: //195/CFCD58F0807D/CCAPI/cc_api_call_disconnect_done:

Disposition=0, Interface=0x4674BFEC, Tag=0x0, Call Id=195,

Call Entry(Disconnect Cause=1, Voice Class Cause Code=0, Retry Count=0)

*Dec 6 06:03:34.143: //195/CFCD58F0807D/CCAPI/cc_api_call_disconnect_done:

Call Disconnect Event Sent

*Dec 6 06:03:34.143: //194/CFCD58F0807D/CCAPI/ccCallDisconnect:

Cause Value=1, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Ca

use=0)

*Dec 6 06:03:34.147: //194/CFCD58F0807D/CCAPI/ccCallDisconnect:

Cause Value=1, Call Entry(Responsed=TRUE, Cause Value=1)

*Dec 6 06:03:34.147: //194/CFCD58F0807D/CCAPI/cc_api_get_transfer_info:

Transfer Number Is Null

*Dec 6 06:03:55.135: //194/CFCD58F0807D/CCAPI/cc_api_call_disconnect_done:

Disposition=0, Interface=0x4603981C, Tag=0x0, Call Id=194,

Call Entry(Disconnect Cause=1, Voice Class Cause Code=0, Retry Count=0)

*Dec 6 06:03:55.135: //194/CFCD58F0807D/CCAPI/cc_api_call_disconnect_done:

Call Disconnect Event Sent

Best regards

Muhammad Asif Khan

Sr. Network Engineer

0092-333-3459514

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jeroenhermans Fri, 12/14/2007 - 06:00

Hi,

THis could be a codec issue, try adding this to your voip dial-peers :

codec g711alaw

Please rate the post if helpfull.

Rgds,

Jeroen

hguillory1 Mon, 02/11/2008 - 19:49

This is definately a codec issue. I had the same problem with an IOS H323 Gateway. Do a debug voice ccapi inout to determine your inbound and outbound dialpeers. In my case I had 8 POTS lines with opx 2100 where 2100 matched a voip dial-peer for 21..

The initial problem was that my voip dialpeer explicitly had codec g711ulaw defined. The problem was that the phone that received the re-order tone was set to use g729 between regions.

This is the fix:

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729br8

codec preference 3 g711alaw

codec preference 4 g729r8

dial-peer voice 2100 voip

destination-pattern 21..

voice-class codec 1

session target ipv4:x.x.x.x (IP of CCM)

incoming called-number .

dtmf-relay h245-alphanumeric

no vad

Create a codec voice-class and assign the class to your voip dial-peer so that it can choose the best codec depending on what the endpoint is trying to negotiate.

Regards,

Hunter, CCVP

Actions

This Discussion