Multicast MoH Working in PSTN, doesen't Work on-site.

Answered Question
Dec 6th, 2007
User Badges:

Hi friend,

i've got a big plroblem, i haved configured multicast MoH with CCM/SrSt on remote site. On remote site when i call from PSTN I can hear MoH and when they put me in "waiting",on router SRST i see that Multicast MoH is working good . But the problem is when the customer call on-site, they can't hear MoH. what can be the problem?

Correct Answer by allan.thomas about 9 years 7 months ago

Matteo, firstly I want clarify that I understand your topolgy, essentially you have a hub and spoke WAN with SRST at the remote branches which also provide MMoH?


If my understanding is correct, then the fact the 'show ccm-manager music' indicates that the CallManager is allocating the MMoH request, and therefore it is correctly configured for MMoH.


Ensure that your MMoH server/audio-source is associated with a device-pool where the region is configured to stream G711 to all other regions/remote branches. MMoH on IOS only support G711.


Two aspects which you initially try, firstly verify with 'show ephone summary' that the audio-file does not show invalid or in error.


If the file does show invalid then try removing and re-applying call-manager-fallback', this should correct the problem.


Secondly, add the gig0/0 interface to the mmoh command under call-manager-fallback:-


'multicast moh 239.1.1.1 port 16384 route 10.254.254.1 10.9.202.3'


Hope this helps.

Regards

Allan.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
allan.thomas Thu, 12/06/2007 - 08:36
User Badges:
  • Blue, 1500 points or more

Make sure that you have the 'ccm-manager music' command configured on the voice gateway.


Regards

Allan.

matteo.margheritini Thu, 12/06/2007 - 09:07
User Badges:

the command issued were present in configuration , "ccm-manager music-on-old", but the problems is already present!

allan.thomas Thu, 12/06/2007 - 13:01
User Badges:
  • Blue, 1500 points or more

Please post the output of a 'show ccm-manager music' when you have a PSTN on-call on-hold, and also the configuration of the SRST gateway if possible.


Regards

Allan.

matteo.margheritini Fri, 12/07/2007 - 06:12
User Badges:

H323-Argelato#sh ccm-manager music-on-hold

Current active multicast sessions : 1

Multicast RTP port Packets Call Codec Incoming

Address number in/out id Interface

===================================================================

239.1.1.1 16384 248/248 143540 g711ulaw Lo0



Attachment: 
allan.thomas Fri, 12/07/2007 - 16:02
User Badges:
  • Blue, 1500 points or more

Matteo, thank you for providing the information I request, however I need to understand the exact issue.


What I need to know or clarify is what you mean when you say when the customer calls on-site, to you calling into remote-site from PSTN?


Regards

Allan.

matteo.margheritini Mon, 12/10/2007 - 01:27
User Badges:

For calls on-site i mean for example all calls in a location. I try to explain: i have two remote CCM, this remotes CCM provide he's services to 20 remote site that are built whit a router SRST in a MPLS network. When the customer make a call from 1 of this remote site and the call renain on the remote site, they can't hear the music-on-hold!

mohammednw Mon, 12/10/2007 - 02:02
User Badges:

Hi


understand that the call remains on site but if the CCM is not resident on the same site, (i mean if the CCM is on the other site) still u need to enable multicast routing.....


because if i am not wrong the source of the MOH is the call manager and its not being able to route the MOH to the destination router....


forgive me if i am wrong...

Avner Izhar Fri, 12/07/2007 - 23:49
User Badges:
  • Bronze, 100 points or more

Hi,


You will need to enable some sort of multicast routing for the stream to go somewhere.


How is your voice gw connected to the local IP Phones?


Regards, Avner.

mohammednw Sun, 12/09/2007 - 02:48
User Badges:

exactly......


multicast routing has to be enabled on the routers....


following is the syntax


in global configuration mode


ip multicas-routing


on the interfaces


ip pim dense-mode

ip join group


i dont exactly remember the syntax but this is just an indicative of what u need to do

Correct Answer
allan.thomas Tue, 12/11/2007 - 05:03
User Badges:
  • Blue, 1500 points or more

Matteo, firstly I want clarify that I understand your topolgy, essentially you have a hub and spoke WAN with SRST at the remote branches which also provide MMoH?


If my understanding is correct, then the fact the 'show ccm-manager music' indicates that the CallManager is allocating the MMoH request, and therefore it is correctly configured for MMoH.


Ensure that your MMoH server/audio-source is associated with a device-pool where the region is configured to stream G711 to all other regions/remote branches. MMoH on IOS only support G711.


Two aspects which you initially try, firstly verify with 'show ephone summary' that the audio-file does not show invalid or in error.


If the file does show invalid then try removing and re-applying call-manager-fallback', this should correct the problem.


Secondly, add the gig0/0 interface to the mmoh command under call-manager-fallback:-


'multicast moh 239.1.1.1 port 16384 route 10.254.254.1 10.9.202.3'


Hope this helps.

Regards

Allan.

matteo.margheritini Wed, 01/02/2008 - 02:13
User Badges:

Thanks for all man, but now i have another problem, in one "Spoke" i can't hear moh when i call from PSTN. what can be the problem? in attach a debug of the problem



Attachment: 

Actions

This Discussion