Cannont hear or speak on outbound calls

Unanswered Question
Dec 6th, 2007
User Badges:
  • Bronze, 100 points or more

Running a new environment with CM 4.2(3) and gateway configured as h323.


Inbound calls are working fine both ways and under show voice call stat i see the call is using g729r8

Outbound calls are connecting but no sound. on the phone i can see that it is transmitting RTP not receiving any from gateway. in the gateway i see the call is using g711.


Any reasons why inbound and outbound calls are using different codecs?


I tried to change the codec for inbound calls by placing codec g711ulaw under my voip dial-peer but then I got the same issue with outbound calls could no RTP packets being received from gateway.

dial-peer voice 10 voip

destination-pattern 6...

session ipv4: 1.1.1.1

codec g711ulaw


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
allan.thomas Thu, 12/06/2007 - 14:18
User Badges:
  • Blue, 1500 points or more

Can you confirm that you have bound h323-gateway to specific ip address under the interface which the CallManager endpoint is configure to?


For example

interface loopback0

ip address 192.168.1.1 255.255.255.0

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.1.1


Another possibilities is that the answer supervision does not get sent correctly when the called device beyond the telco answers the call.


In this instance, failure to receive the answer supervision will cause the gateway not to cut through the audio path in a forward direction which causes one-way voice.


A workaround involves the need to configure 'voice rtp send-recv on' in global configuration.


In some cases you need to establish a two-way audio path as soon as the RTP channel is opened-before the connect message is received from the telco. Try using the command 'voice rtp send-recv' in global configuration.


Hope this helps.


Regards

Allan.

Actions

This Discussion