how to debalance two identical uplinks within the same AS?

Unanswered Question
Dec 7th, 2007
User Badges:

Hi all.


I have a question regarding debalancing of the two equal uplinks within the same AS. I have two routers that have BGP established between them. Although we are couple of hundreds of miles away, we do belong to the same autonomous system.

We have established two redundant links, both 100Mbps of bandwidth. At the moment we have set up neighboring and we do have BGP balancing links almost perfectly - automatically splitting traffic in half. Now, what I want to do, is to debalance those links. Reason is that each link uses separate com. channels - first one is going via my main STM-1 link, later one is going through protection channel.


What I want is that my network prefers first link over the second one, but to automatically switch onto the second link in the case first one is experiencing delays, heavy traffic, or looses connectivity. I would like to use first (primary) link for about 80 or 90% of my traffic, and to use second(ary) link for the rest of the traffic, unless first link fails.


As far as I could've figure this out, I think I need to set EIGRP load balancing in order to do such thing (debalance two equal links, in ratio 90% - 10%) (link is here http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009437d.shtml#topic1 )


Please do say if you have any better advice how to do such thing, I would really appreciate someone else's thoughts on this. Thank you in advance!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
mheusing Fri, 12/07/2007 - 02:38
User Badges:
  • Cisco Employee,

Hi,


There is one other feature allowing for very granular unequal cost load balancing: MPLS traffic engineering.

In MPLS TE you can setup two tunnels to the same destination and use load balancing based on the configured tunnel bandwidth parameter. There is a restriction though, which is stemming from the way CEF achieves the load balancing: there are 16 "buckets", i.e. a certain number of "buckets" are assigned to each tunnel. Examples:

A) 9:1 use 9 buckets for tunnel 1 and 1 bucket for tunnel 2 not using

B) 20:7 will be translated to 11:5 or so


Be aware, that you need ISIS or OSPF as the IGP to use MPLS TE. Also be aware, that the load sharing ratio will be static, i.e. not based on traffic drops, overload, CRC errors and such.


Other than that, MPLS TE will deliver all the requested features.


Example config for 9:1 load sharing:


ip cef

mpls traffic-eng tunnels

interface loopback 0

ip address 11.11.11.11 255.255.255.255

ip router isis


interface GigabitEthernet0/0/0

ip address 10.1.1.1 255.255.255.252

ip router isis

mpls traffic-eng tunnels

ip rsvp bandwidth


interface GigabitEthernet0/0/1

ip address 10.1.2.1 255.255.255.252

ip router isis

mpls traffic-eng tunnels

ip rsvp bandwidth


interface tunnel1

ip unnumbered loopback 0

tunnel destination 17.17.17.17

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng bandwidth 90 !based on this ratio load sharing will be done

tunnel mpls traffic-eng priority 1 1

tunnel mpls traffic-eng path-option 1 explicit identifier p1


interface tunnel2

ip unnumbered loopback 0

tunnel destination 17.17.17.17

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng bandwidth 10 !based on this ratio load sharing will be done

tunnel mpls traffic-eng priority 1 1

tunnel mpls traffic-eng path-option 1 explicit identifier p2


router isis

network 47.0000.0011.0011.00

is-type level-1

metric-style wide

mpls traffic-eng router-id loopback0

mpls traffic-eng level-1


ip explicit-path identifier p1

next-address 10.1.1.2


ip explicit-path identifier p2

next-address 10.1.2.2


ip route 17.17.17.17 255.255.255.255 tunnel1

ip route 17.17.17.17 255.255.255.255 tunnel2


Assuming you have a BGP session between 11.11.11.11 and 17.17.17.17.


For a more detailed discussion and configuration examples have a look at f.e. the MPLS configuration guide for IOS 12.4

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a00800ca7fa_4container_ccmigration_09186a00804402b1.html


Hope this helps! Please rate all posts.


Regards, Martin


XXLuciano Fri, 12/07/2007 - 06:52
User Badges:

Thank you very much for the effort. However, I need to be sure that those links will be redundant for each other - that is the main idea, so as you said - such balancing is static and it does not work for me, I need those unbalanced links to be able to replace each other in the case of link failure, and that is a must - I will rather forget about unbalancing them than use static distribution.

Actions

This Discussion